package/mplayer: Fix linking with libvorbis/libdvdread
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 8 Nov 2015 15:55:17 +0000 (16:55 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 18 Nov 2015 21:22:31 +0000 (22:22 +0100)
Fixes
http://autobuild.buildroot.net/results/7f6/7f6e5396e95a3c3b676ca59bedc5317aa88e5f4c/
http://autobuild.buildroot.net/results/6ac/6acd9cf25c3088d313247510db47a214fff30c67/
http://autobuild.buildroot.net/results/a0d/a0da41bb734dbcdb17e13d852cfbdba5e069429e/
http://autobuild.buildroot.net/results/d0c/d0caf60c1ddf4e05086c93f646e32b5ddc75b6ce/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mplayer/mplayer.mk

index 99fc469f6a43939f8e0aaf8b141264dfbb8222b4..ad2d9dd61345e7215becfefb5afc27c1f0f1581a 100644 (file)
@@ -117,9 +117,10 @@ endif
 # https://github.com/pld-linux/mplayer/blob/master/mplayer-libcdio.patch
 MPLAYER_CONF_OPTS += --disable-libcdio
 
+# We intentionally don't pass --enable-dvdread, to let the
+# autodetection find which library to link with.
 ifeq ($(BR2_PACKAGE_LIBDVDREAD),y)
 MPLAYER_CONF_OPTS +=  \
-       --enable-dvdread \
        --with-dvdread-config=$(STAGING_DIR)/usr/bin/dvdread-config
 MPLAYER_DEPENDENCIES += libdvdread
 endif
@@ -175,9 +176,10 @@ MPLAYER_DEPENDENCIES += tremor
 MPLAYER_CONF_OPTS += --enable-tremor
 endif
 
+# We intentionally don't pass --enable-libvorbis, to let the
+# autodetection find which library to link with.
 ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
 MPLAYER_DEPENDENCIES += libvorbis
-MPLAYER_CONF_OPTS += --enable-libvorbis
 endif
 
 ifeq ($(BR2_PACKAGE_LIBMAD),y)