libpqxx: new package
authorJames Knight <james.knight@rockwellcollins.com>
Thu, 28 Jul 2016 21:44:58 +0000 (17:44 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 30 Jul 2016 13:42:30 +0000 (15:42 +0200)
Signed-off-by: James Knight <james.knight@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libpqxx/Config.in [new file with mode: 0644]
package/libpqxx/libpqxx.hash [new file with mode: 0644]
package/libpqxx/libpqxx.mk [new file with mode: 0644]

index f11ea9f285efdd82d9994f5be6636758477c694c..5584d36df60eb259bb300e888379053776695637 100644 (file)
@@ -899,6 +899,7 @@ menu "Database"
        source "package/gdbm/Config.in"
        source "package/kompexsqlite/Config.in"
        source "package/leveldb/Config.in"
+       source "package/libpqxx/Config.in"
        source "package/mongodb/Config.in"
        source "package/mysql/Config.in"
        source "package/postgresql/Config.in"
diff --git a/package/libpqxx/Config.in b/package/libpqxx/Config.in
new file mode 100644 (file)
index 0000000..ddf14fd
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_LIBPQXX
+       bool "libpqxx"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_PACKAGE_POSTGRESQL
+       help
+         libpqxx is the official C++ client API for PostgreSQL, the
+         enterprise-strength open-source relational database.
+
+         http://pqxx.org/development/libpqxx/
+
+comment "libpqxx needs toolchain w/ C++ support"
+       depends on !BR2_INSTALL_LIBSTDCPP
+       depends on BR2_PACKAGE_POSTGRESQL
diff --git a/package/libpqxx/libpqxx.hash b/package/libpqxx/libpqxx.hash
new file mode 100644 (file)
index 0000000..65c50c6
--- /dev/null
@@ -0,0 +1,4 @@
+# From: http://pqxx.org/download/software/libpqxx/libpqxx-4.0.1.tar.gz.md5sum
+md5    6ea888b9ba85dd7cef1b182dc5f223a2  libpqxx-4.0.1.tar.gz
+# Locally computed after verifying md5sum:
+sha256 097ceda2797761ce517faa5bee186c883df1c407cb2aada613a16773afeedc38  libpqxx-4.0.1.tar.gz
diff --git a/package/libpqxx/libpqxx.mk b/package/libpqxx/libpqxx.mk
new file mode 100644 (file)
index 0000000..0587190
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# libpqxx
+#
+################################################################################
+
+LIBPQXX_VERSION = 4.0.1
+LIBPQXX_SITE = http://pqxx.org/download/software/libpqxx
+LIBPQXX_INSTALL_STAGING = YES
+LIBPQXX_DEPENDENCIES = postgresql
+LIBPQXX_LICENSE = BSD-3c
+LIBPQXX_LICENSE_FILES = COPYING
+
+LIBPQXX_CONF_ENV += ac_cv_path_PG_CONFIG=$(STAGING_DIR)/usr/bin/pg_config
+
+$(eval $(autotools-package))