projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5ddfc12
)
Makefile.cmake.in: fix automatic host deps calculation
author
Peter Korsgaard
<jacmet@sunsite.dk>
Sun, 26 Feb 2012 07:24:23 +0000
(08:24 +0100)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Sun, 26 Feb 2012 07:24:23 +0000
(08:24 +0100)
We need similar handling as in autotools because of the host-cmake addition.
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.cmake.in
patch
|
blob
|
history
diff --git
a/package/Makefile.cmake.in
b/package/Makefile.cmake.in
index 38e459b80cdae79b4641a80c3ca316e6b705f508..4a4ad6e2d43c85dcd0356b368ca1d6fdc8c07a6b 100644
(file)
--- a/
package/Makefile.cmake.in
+++ b/
package/Makefile.cmake.in
@@
-96,6
+96,10
@@
endef
endif
endif
+# This must be repeated from GENTARGETS_INNER, otherwise we only get
+# host-cmake in _DEPENDENCIES because of the following line
+$(2)_DEPENDENCIES ?= $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES)))
+
$(2)_DEPENDENCIES += host-cmake
#