package/qt5/qt5knx: new package
authorAngelo Compagnucci <angelo@amarulasolutions.com>
Tue, 24 Nov 2020 06:59:17 +0000 (07:59 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 6 Dec 2020 10:15:54 +0000 (11:15 +0100)
The Qt KNX module implements the client side of a connection between a
client and a KNXnet/IP server.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/qt5/Config.in
package/qt5/qt5knx/Config.in [new file with mode: 0644]
package/qt5/qt5knx/qt5knx.hash [new file with mode: 0644]
package/qt5/qt5knx/qt5knx.mk [new file with mode: 0644]

index dc0a104862ee57b0a782c67d25db344bf7ff09ce..f33f88df432f87ea1022fa61bc0478f5e6667c18 100644 (file)
@@ -170,6 +170,7 @@ F:  package/python-pydal/
 F:     package/python-spidev/
 F:     package/python-web2py/
 F:     package/qt5/qt5coap/
+F:     package/qt5/qt5knx/
 F:     package/qt5/qt5mqtt/
 F:     package/sam-ba/
 F:     package/sshguard/
index c15d27ba7cb655eb459840e19f6e6f4012628a87..6714c6271dbac3f21f2f2a2035b21f323f49d735 100644 (file)
@@ -46,6 +46,7 @@ source "package/qt5/qt5declarative/Config.in"
 source "package/qt5/qt5enginio/Config.in"
 source "package/qt5/qt5graphicaleffects/Config.in"
 source "package/qt5/qt5imageformats/Config.in"
+source "package/qt5/qt5knx/Config.in"
 source "package/qt5/qt5location/Config.in"
 source "package/qt5/qt5lottie/Config.in"
 source "package/qt5/qt5mqtt/Config.in"
diff --git a/package/qt5/qt5knx/Config.in b/package/qt5/qt5knx/Config.in
new file mode 100644 (file)
index 0000000..991e93c
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_QT5KNX
+       bool "qt5knx"
+       help
+         Qt is a cross-platform application and UI framework for
+         developers using C++.
+
+         The Qt KNX module implements the client side of a connection
+         between a client and a KNXnet/IP server. This connection
+         can be used to send messages to the KNX bus and to control
+         the functionalities of the KNX devices.
+
+         https://doc.qt.io/QtKNX/index.html
diff --git a/package/qt5/qt5knx/qt5knx.hash b/package/qt5/qt5knx/qt5knx.hash
new file mode 100644 (file)
index 0000000..05abe70
--- /dev/null
@@ -0,0 +1,6 @@
+# Hash locally calculated
+sha256  8ee0df130fad39ef6b9a0bef390b648d3ad6539ffca33e22fb569e889d0bd043  qt5knx-5.15.1.tar.gz
+
+# Hashes for license files:
+sha256  8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  LICENSE.GPL3
+sha256  f827ad079686ba92cc94811e35492d0e8966f704008b6da9eeda0b659fb58a8d  LICENSE.FDL
diff --git a/package/qt5/qt5knx/qt5knx.mk b/package/qt5/qt5knx/qt5knx.mk
new file mode 100644 (file)
index 0000000..494e632
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# qt5knx
+#
+################################################################################
+
+QT5KNX_VERSION = $(QT5_VERSION)
+QT5KNX_SITE = $(call github,qt,qtknx,v$(QT5_VERSION))
+QT5KNX_INSTALL_STAGING = YES
+QT5KNX_LICENSE = GPL-3.0 with exception
+QT5KNX_LICENSE_FILES = LICENSE.GPL3 LICENSE.GPL3-EXCEPT
+QT5KNX_SYNC_QT_HEADERS = YES
+
+$(eval $(qmake-package))