package/libvips: add poppler optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 30 Mar 2021 21:43:31 +0000 (23:43 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 31 Mar 2021 07:24:15 +0000 (09:24 +0200)
poppler is an optional dependency which is enabled by default since
version 8.3.0 and
https://github.com/libvips/libvips/commit/8da4e706dd60aba1a69e49bd562d8de225d2404d

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libvips/libvips.mk

index d0979b7e3b7fab9bb501a380a02b8be07c303ad5..014aaf03279054ff1d5814b2c51b5b3ae6d58668 100644 (file)
@@ -59,6 +59,13 @@ else
 LIBVIPS_CONF_OPTS += --without-png
 endif
 
+ifeq ($(BR2_PACKAGE_POPPLER),y)
+LIBVIPS_CONF_OPTS += --with-poppler
+LIBVIPS_DEPENDENCIES += poppler
+else
+LIBVIPS_CONF_OPTS += --without-poppler
+endif
+
 ifeq ($(BR2_PACKAGE_TIFF),y)
 LIBVIPS_CONF_OPTS += --with-tiff
 LIBVIPS_DEPENDENCIES += tiff