package/pulseaudio: add optional support for libsoxr
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 Feb 2016 09:50:15 +0000 (10:50 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 11:43:36 +0000 (12:43 +0100)
When libsoxr was compiled before, pulseaudio will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/pulseaudio | grep NEEDED
 0x0000000000000001 (NEEDED)             Shared library: [libpulsecore-8.0.so]
 0x0000000000000001 (NEEDED)             Shared library: [libpulse.so.0]
 0x0000000000000001 (NEEDED)             Shared library: [libspeexdsp.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libsoxr.so.0]
[...]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pulseaudio/pulseaudio.mk

index cd8d0f9e50e05e3e72728affd534d717724fd72d..36661ccd000af67df7792d1401e34422d892eb2b 100644 (file)
@@ -72,6 +72,13 @@ else
 PULSEAUDIO_CONF_OPTS += --disable-gtk3
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSOXR),y)
+PULSEAUDIO_CONF_OPTS += --with-soxr
+PULSEAUDIO_DEPENDENCIES += libsoxr
+else
+PULSEAUDIO_CONF_OPTS += --without-soxr
+endif
+
 ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
 # The optional webrtc echo canceller is written in C++, causing auto* to want
 # to link module-echo-cancel.so with CXX even if webrtc ISN'T used.