pinentry: link with libatomic when needed
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 14 Jun 2018 18:02:04 +0000 (20:02 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 17 Jun 2018 21:24:48 +0000 (23:24 +0200)
On some architectures, atomic binutils are provided by the libatomic
library from gcc. Linking with libatomic is therefore necessary,
otherwise the build fails with:

sparc-buildroot-linux-uclibc/sysroot/lib/libatomic.so.1: error adding symbols: DSO missing from command line

This is often for example the case on sparcv8 32 bit.

Fixes:

 http://autobuild.buildroot.net/results/fd6bee70ff20bee9607a9f6f557a3a793d00cd9f

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Thomas: use LIBS instead of LDFLAGS.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pinentry/pinentry.mk

index 4081a8a5d668b8ef15a029df1b5b4d5508937170..d0179728bdea2bd9d2460bfcd40f14e89a140750 100644 (file)
@@ -18,6 +18,10 @@ PINENTRY_CONF_OPTS += \
        --with-libgpg-error-prefix=$(STAGING_DIR)/usr \
        --without-libcap       # requires PAM
 
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+PINENTRY_CONF_ENV += LIBS=-latomic
+endif
+
 # build with X if available
 ifeq ($(BR2_PACKAGE_XORG7),y)
 PINENTRY_CONF_OPTS += --with-x