python-ipython: new package
authorPhilippe Proulx <eeppeliteloop@gmail.com>
Thu, 24 Jul 2014 19:08:49 +0000 (15:08 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 27 Jul 2014 13:37:27 +0000 (15:37 +0200)
Signed-off-by: Philippe Proulx <eeppeliteloop@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-ipython/Config.in [new file with mode: 0644]
package/python-ipython/python-ipython-001-set-correct-python-executable-path.patch [new file with mode: 0644]
package/python-ipython/python-ipython.mk [new file with mode: 0644]

index ce479842f32c76adfd2002f9f1ec06970988d77d..6b80ee223903994d1d997bd33358249118f40eae 100644 (file)
@@ -476,6 +476,7 @@ menu "external python modules"
        source "package/python-flup/Config.in"
        source "package/python-id3/Config.in"
        source "package/python-ipy/Config.in"
+       source "package/python-ipython/Config.in"
        source "package/python-json-schema-validator/Config.in"
        source "package/python-keyring/Config.in"
        source "package/python-libconfig/Config.in"
diff --git a/package/python-ipython/Config.in b/package/python-ipython/Config.in
new file mode 100644 (file)
index 0000000..064f0c9
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PYTHON_IPYTHON
+       bool "python-ipython"
+       depends on BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3
+       help
+         IPython is a command shell for interactive computing in multiple
+         programming languages, originally developed for the Python
+         programming language, that offers enhanced introspection, rich
+         media, additional shell syntax, tab completion, and rich history.
+
+         http://ipython.org/
diff --git a/package/python-ipython/python-ipython-001-set-correct-python-executable-path.patch b/package/python-ipython/python-ipython-001-set-correct-python-executable-path.patch
new file mode 100644 (file)
index 0000000..0fbd5a1
--- /dev/null
@@ -0,0 +1,15 @@
+Set correct Python executable path
+
+Signed-off-by: Philippe Proulx <eeppeliteloop@gmail.com>
+
+--- python-ipython-2.1.0/setupbase.py  2014-05-21 15:19:12.000000000 -0400
++++ python-ipython-2.1.0-new/setupbase.py      2014-07-23 23:34:32.892030423 -0400
+@@ -394,7 +394,7 @@ class build_scripts_entrypt(build_script
+             mod, func = entrypt.split(':')
+             with open(outfile, 'w') as f:
+-                f.write(script_src.format(executable=sys.executable,
++                f.write(script_src.format(executable='/usr/bin/env python',
+                                           mod=mod, func=func))
+         return outfiles, outfiles
diff --git a/package/python-ipython/python-ipython.mk b/package/python-ipython/python-ipython.mk
new file mode 100644 (file)
index 0000000..d1daa7f
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-ipython
+#
+################################################################################
+
+PYTHON_IPYTHON_VERSION = 2.1.0
+PYTHON_IPYTHON_SOURCE = ipython-$(PYTHON_IPYTHON_VERSION).tar.gz
+PYTHON_IPYTHON_SITE = https://pypi.python.org/packages/source/i/ipython/
+PYTHON_IPYTHON_LICENSE = BSD-3c
+PYTHON_IPYTHON_LICENSE_FILES = COPYING.rst
+PYTHON_IPYTHON_SETUP_TYPE = distutils
+
+$(eval $(python-package))