modplugtools: Added package
authorMaarten ter Huurne <maarten@treewalker.org>
Sun, 19 Oct 2014 00:00:46 +0000 (02:00 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 19 Oct 2014 09:40:08 +0000 (11:40 +0200)
This installs the 'modplug123' command line tool to play tracker music
files (MOD, S3M, XM etc.) using libmodplug.

The modplugtools package can build two players: modplugplay that plays
directly via OSS and modplug123 that plays via libao. Since modplugplay
won't work without OSS support and modern kernels are likely to have no
OSS or OSS emulation, we build only modplug123.

If you have a system without ALSA support for some reason, you can
still use modplug123 to play over OSS via libao.

http://modplug-xmms.sourceforge.net/

[Thomas: add missing Config.in comment about the C++ dependency.]

Signed-off-by: Maarten ter Huurne <maarten@treewalker.org>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/modplugtools/Config.in [new file with mode: 0644]
package/modplugtools/modplugtools.mk [new file with mode: 0644]

index 4c6685a89fd31b61784a5a36ac7cfadb26bc3499..8b8a20f09927277bcae2ba46ac05b839137413e8 100644 (file)
@@ -17,6 +17,7 @@ menu "Audio and video applications"
        source "package/lame/Config.in"
        source "package/libvpx/Config.in"
        source "package/madplay/Config.in"
+       source "package/modplugtools/Config.in"
        source "package/mpd/Config.in"
        source "package/mpg123/Config.in"
        source "package/mplayer/Config.in"
diff --git a/package/modplugtools/Config.in b/package/modplugtools/Config.in
new file mode 100644 (file)
index 0000000..89c3220
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_MODPLUGTOOLS
+       bool "modplugtools"
+       depends on BR2_INSTALL_LIBSTDCPP # libmodplug
+       select BR2_PACKAGE_LIBAO
+       select BR2_PACKAGE_LIBMODPLUG
+       help
+         This installs the 'modplug123' command line tool to play music files
+         in the tracker formats supported by libmodplug: MOD, S3M, XM etc.
+         Audio output is handled by libao.
+
+         http://modplug-xmms.sourceforge.net/
+
+comment "modplugtools needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/modplugtools/modplugtools.mk b/package/modplugtools/modplugtools.mk
new file mode 100644 (file)
index 0000000..e8d73af
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# modplugtools
+#
+################################################################################
+
+MODPLUGTOOLS_VERSION = 0.5.3
+MODPLUGTOOLS_SITE = http://downloads.sourceforge.net/project/modplug-xmms/modplug-tools
+MODPLUGTOOLS_LICENSE = GPLv3
+MODPLUGTOOLS_LICENSE_FILES = COPYING
+
+MODPLUGTOOLS_DEPENDENCIES = libao libmodplug
+
+# Only build the 'mp123' subdir, which contains 'modplug123' that plays through
+# various backends via libao. This excludes the 'mpplay' subdir, which contains
+# 'modplugplay' that can play only through the deprecated OSS interface.
+MODPLUGTOOLS_MAKE_OPTS = SUBDIRS=mp123
+MODPLUGTOOLS_INSTALL_TARGET_OPTS = SUBDIRS=mp123 DESTDIR=$(TARGET_DIR) install
+
+$(eval $(autotools-package))