noip: add $(TARGET_MAKE_ENV) before $(MAKE)
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Tue, 20 Oct 2015 13:52:54 +0000 (14:52 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 21 Oct 2015 20:12:47 +0000 (22:12 +0200)
For consistency reasons, this commit adjusts the noip package to pass
$(TARGET_MAKE_ENV) in the environment when calling $(MAKE).

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/noip/noip.mk

index 98edfcac54ae49cdec7ea8839bf96021670bc076..a61d141832731e11618a23b2a36206fb88e42818 100644 (file)
@@ -12,8 +12,8 @@ NOIP_LICENSE_FILES = COPYING
 
 define NOIP_BUILD_CMDS
        $(SED) "/^#define CONFIG_FILENAME/ s/PREFIX//" $(@D)/noip2.c
-       $(MAKE) -C $(@D) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
-               PREFIX=/usr CONFDIR=/etc
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CFLAGS)" PREFIX=/usr CONFDIR=/etc
 endef
 
 define NOIP_INSTALL_TARGET_CMDS