package/luaossl: new package
authorMarcin Niestroj <m.niestroj@grinn-global.com>
Mon, 29 May 2017 14:32:05 +0000 (16:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 31 May 2017 19:28:18 +0000 (21:28 +0200)
Signed-off-by: Marcin Niestroj <m.niestroj@grinn-global.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/luaossl/Config.in [new file with mode: 0644]
package/luaossl/luaossl.hash [new file with mode: 0644]
package/luaossl/luaossl.mk [new file with mode: 0644]

index f86e5c6b7582330529e712ec2c8f87b51fb7d222..5e8b6959ec0d3b967b91bda0483537de53f2bd68 100644 (file)
@@ -1039,6 +1039,7 @@ F:        board/grinn/
 F:     configs/grinn_*
 F:     package/argparse/
 F:     package/easydbus/
+F:     package/luaossl/
 F:     package/rs485conf/
 F:     package/turbolua/
 
index 1b150b2f5b9d0f98501068ebf37f16c8ffc4efd1..c1c6e651c2f5a2f0dcfbe8de244f582254a1e9e1 100644 (file)
@@ -573,6 +573,7 @@ menu "Lua libraries/modules"
        source "package/luafilesystem/Config.in"
        source "package/luajson/Config.in"
        source "package/lualogging/Config.in"
+       source "package/luaossl/Config.in"
        source "package/luaposix/Config.in"
        source "package/lua-resty-http/Config.in"
        source "package/luasec/Config.in"
diff --git a/package/luaossl/Config.in b/package/luaossl/Config.in
new file mode 100644 (file)
index 0000000..d8763e7
--- /dev/null
@@ -0,0 +1,18 @@
+config BR2_PACKAGE_LUAOSSL
+       bool "luaossl"
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       select BR2_PACKAGE_OPENSSL
+       help
+         luaossl is a comprehensive binding to OpenSSL for Lua 5.1,
+         5.2, and later.
+
+         It includes support for certificate and key management,
+         key generation, signature verification, and deep bindings
+         to the distinguished name, alternative name, and X.509v3
+         extension interfaces. It also binds OpenSSL's bignum, message
+         digest, HMAC, cipher, and CSPRNG interfaces.
+
+         http://25thandclement.com/~william/projects/luaossl.html
+
+comment "luaossl needs a toolchain w/ threads"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/luaossl/luaossl.hash b/package/luaossl/luaossl.hash
new file mode 100644 (file)
index 0000000..ea9f5e3
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 51641d8971c19b2c65d3954ded12c306d4ecf6315ff8f1ec584e9a23ca998576  luaossl-20161214-0.src.rock
diff --git a/package/luaossl/luaossl.mk b/package/luaossl/luaossl.mk
new file mode 100644 (file)
index 0000000..5bb3e82
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# luaossl
+#
+################################################################################
+
+LUAOSSL_VERSION_UPSTREAM = 20161214
+LUAOSSL_VERSION = $(LUAOSSL_VERSION_UPSTREAM)-0
+LUAOSSL_SUBDIR = luaossl-rel-$(LUAOSSL_VERSION_UPSTREAM)
+LUAOSSL_LICENSE = MIT
+LUAOSSL_LICENSE_FILES = $(LUAOSSL_SUBDIR)/LICENSE
+LUAOSSL_DEPENDENCIES = openssl
+
+$(eval $(luarocks-package))