package/findutils: Fix compile error
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 19 Oct 2014 16:24:42 +0000 (18:24 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 19 Oct 2014 20:51:18 +0000 (22:51 +0200)
Error occured with an allyespackageconfig setup:

/home/fli4l/br5/output/host/usr/bin/i586-buildroot-linux-uclibc-gcc -std=gnu99  -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -pipe -Os -g2   -o find ftsfind.o ./libfindtools.a ../lib/libfind.a ../gnulib/lib/libgnulib.a -lintl  -lm -lm
../gnulib/lib/libgnulib.a(getdate.o): In function `get_date':
getdate.c:(.text+0x15cd): undefined reference to `rpl_mktime'
getdate.c:(.text+0x168e): undefined reference to `rpl_mktime'
getdate.c:(.text+0x1707): undefined reference to `rpl_mktime'
getdate.c:(.text+0x1812): undefined reference to `rpl_mktime'
collect2: error: ld returned 1 exit status
make[3]: *** [find] Error 1
make[3]: Leaving directory `/home/fli4l/br5/output/build/findutils-4.4.2/find'

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/findutils/findutils.mk

index d9b6050963c077dcf946d44a72bd6aab7daef72c..3caedf8cc0bfdeeac548b5584d75d17699a9fe10 100644 (file)
@@ -9,6 +9,7 @@ FINDUTILS_SITE = $(BR2_GNU_MIRROR)/findutils
 FINDUTILS_LICENSE = GPLv3+
 FINDUTILS_LICENSE_FILES = COPYING
 FINDUTILS_CONF_ENV = gl_cv_func_stdin=yes \
+                       ac_cv_func_working_mktime=yes \
                        gl_cv_func_wcwidth_works=yes
 
 $(eval $(autotools-package))