Makefile: fix make <blah>_defconfig
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 21 Jun 2010 20:13:20 +0000 (22:13 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 21 Jun 2010 20:16:34 +0000 (22:16 +0200)
Make sure we only pass O=<path> if we were originally called like that,
otherwise we might end up looking for the .config in the wrong place.

Likewise, when changing between using O= or not (or simply running
make <blah>_defconfig in a pristine source tree), we do end up having
a .config, but no .config.cmd. It isn't really critical so just continue
even if we couldn't read it.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index ef78de120695f20cdc3d7a9ee686d48ab70576c9..c8f211b65ebc17f17556bf9b151bec421b52def9 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -287,7 +287,7 @@ include package/Makefile.in
 all: world
 
 # In this section, we need .config
-include $(CONFIG_DIR)/.config.cmd
+-include $(CONFIG_DIR)/.config.cmd
 
 # We also need the various per-package makefiles, which also add
 # each selected package to TARGETS if that package was selected
@@ -587,7 +587,11 @@ flush:
 
 %_defconfig: $(TOPDIR)/configs/%_defconfig
        cp $^ $(CONFIG_DIR)/.config
+ifeq ($(O),output)
+       @$(MAKE) oldconfig
+else
        @$(MAKE) O=$(O) oldconfig
+endif
 
 configured: dirs host-sed kernel-headers uclibc-config busybox-config linux26-config