bind: fix static openssl linking
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 30 Jul 2014 20:10:26 +0000 (17:10 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Jul 2014 21:51:51 +0000 (23:51 +0200)
Apparently LIBS (environment) isn't pushed to LIBS (autoconf) for the
tests, hence when static linking openssl it misses libz and assumes some
basic digests required for ecdsa support are missing, which is false. Fixes:
http://autobuild.buildroot.net/results/204/20411901d1bc6811e1ef8fa39457257d6bf1a146/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/bind/bind.mk

index d6707d23d9fc26ff848a720c52e8941098ff7d48..e0784e66a6e25058e2a93c1e0ab5a95baf674a23 100644 (file)
@@ -41,6 +41,8 @@ endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
        BIND_DEPENDENCIES += openssl
+       BIND_CONF_ENV += ac_cv_func_EVP_sha256=yes \
+               ac_cv_func_EVP_sha384=yes ac_cv_func_EVP_sha512=yes
        BIND_CONF_OPT += --with-openssl=$(STAGING_DIR)/usr LIBS="-lz" \
                --with-ecdsa=yes
 # GOST cipher support requires openssl extra engines