package/nbd: bump version
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 12 Mar 2017 09:58:18 +0000 (10:58 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Mar 2017 13:27:55 +0000 (14:27 +0100)
nbd uses fork and threads, so remove the comment about the dependency:
it is not inherited from glib2 anymore (it has not been for a while in
fact).

The dependency on wchar is also a requirement for nbd, because configure
needs wchar to test for C99.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/nbd/Config.in
package/nbd/nbd.hash
package/nbd/nbd.mk

index afe8ad4fe5ccef6b92466e8363c15e35d4d65441..ad9fb5cc5f55e2bc8e3d9485e9d9fb776f5e3c14 100644 (file)
@@ -1,8 +1,8 @@
 config BR2_PACKAGE_NBD
        bool "nbd"
-       depends on BR2_USE_WCHAR # glib2
-       depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
-       depends on BR2_USE_MMU # glib2
+       depends on BR2_USE_WCHAR
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_USE_MMU
        select BR2_PACKAGE_LIBGLIB2
        help
          NBD is a set of utilities to configure network block devices,
index c90682f481793c9cba7ff84d7845e218be533d43..03234fd87666698bf7e20749e13a17e992e9d36e 100644 (file)
@@ -1,3 +1,3 @@
 # From http://sourceforge.net/projects/nbd/files/nbd/3.13/
-md5    784be37497cc2f9a53c67c8c77d1676d        nbd-3.13.tar.xz
-sha1   e43674a2d2b42d20719cba3149748e8f5683e554        nbd-3.13.tar.xz
+md5    f52a4ef8979d81e6c15a745236582fdf        nbd-3.15.2.tar.xz
+sha1   c8248dd76641a31189735407cd4d55fe63969c08        nbd-3.15.2.tar.xz
index 42200eeddd7a5f42cbcd1b5f02beda004486d6b4..7eeadec9416506d23fa1bf59e762cf70b0e3cf04 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-NBD_VERSION = 3.13
+NBD_VERSION = 3.15.2
 NBD_SOURCE = nbd-$(NBD_VERSION).tar.xz
 NBD_SITE = http://downloads.sourceforge.net/project/nbd/nbd/$(NBD_VERSION)
 NBD_CONF_OPTS = --enable-lfs