directfb: remove BR2_PACKAGE_DIRECTFB_UNIQUE option
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 1 Sep 2015 22:01:07 +0000 (00:01 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 10 Sep 2015 11:53:47 +0000 (13:53 +0200)
This option depends on BR2_UNIMPLEMENTED (which does not exist) since
2009. Since BR2_UNIMPLEMENTED does not exist, it was not possible to
enable BR2_PACKAGE_DIRECTFB_UNIQUE, which means that nobody cared
about making it available, and that we don't need to add any
Config.in.legacy handling to remove this option.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/directfb/Config.in
package/directfb/directfb.mk

index 98acec5f04428b413661b55680bd308aad4a912b..d71858e1b2c88e79329163b5e8854de4511e5d37 100644 (file)
@@ -45,10 +45,6 @@ config BR2_PACKAGE_DIRECTFB_TRACE
        help
          Enable call tracing for DirectFB applications
 
-config BR2_PACKAGE_DIRECTFB_UNIQUE
-       bool "enable unique window manager"
-       depends on BR2_UNIMPLEMENTED
-
 config BR2_PACKAGE_DIRECTFB_ATI128
        bool "compile ati128 graphics driver"
        depends on BR2_i386 || BR2_x86_64
index acb3e3addd79c73732b0e837ef2b648d49a7ac8f..d44e658f1b6062ea22520f1055134d51f89376d2 100644 (file)
@@ -53,12 +53,6 @@ ifeq ($(BR2_PACKAGE_DIRECTFB_TRACE),y)
 DIRECTFB_CONF_OPTS += --enable-trace
 endif
 
-ifeq ($(BR2_PACKAGE_DIRECTFB_UNIQUE),y)
-DIRECTFB_CONF_OPTS += --enable-unique
-else
-DIRECTFB_CONF_OPTS += --disable-unique
-endif
-
 DIRECTFB_GFX = \
        $(if $(BR2_PACKAGE_DIRECTFB_ATI128),ati128) \
        $(if $(BR2_PACKAGE_DIRECTFB_CLE266),cle266) \