libfslparser: new package
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 19 Dec 2012 13:37:34 +0000 (13:37 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 14 Jan 2013 14:04:48 +0000 (15:04 +0100)
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/libfslparser/Config.in [new file with mode: 0644]
package/libfslparser/libfslparser.mk [new file with mode: 0644]

index f87e14302ff9bbeee44b9b6dc9ec0600524f922b..44e83f94d44f7b8f9b048574b764742409750ccf 100644 (file)
@@ -468,6 +468,7 @@ menu "Multimedia"
 source "package/libdvdread/Config.in"
 source "package/libdvdnav/Config.in"
 source "package/libebml/Config.in"
+source "package/libfslparser/Config.in"
 source "package/libfslvpuwrap/Config.in"
 source "package/libmatroska/Config.in"
 source "package/libmms/Config.in"
diff --git a/package/libfslparser/Config.in b/package/libfslparser/Config.in
new file mode 100644 (file)
index 0000000..e3ab980
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LIBFSLPARSER
+       bool "libfslparser"
+       depends on BR2_arm # Only relevant for i.MX
+       help
+         Binary parser libraries for the Freescale i.MX SoCs.
+
+         This library is provided by Freescale as-is and doesn't have
+         an upstream.
diff --git a/package/libfslparser/libfslparser.mk b/package/libfslparser/libfslparser.mk
new file mode 100644 (file)
index 0000000..66f48cc
--- /dev/null
@@ -0,0 +1,40 @@
+#############################################################
+#
+# buildroot makefile for libfslparser
+#
+#############################################################
+
+LIBFSLPARSER_VERSION = 3.0.1
+# No official download site from freescale, just this mirror
+LIBFSLPARSER_SITE = http://download.ossystems.com.br/bsp/freescale/source
+LIBFSLPARSER_SOURCE = libfslparser-$(LIBFSLPARSER_VERSION).bin
+LIBFSLPARSER_LICENSE = Freescale Semiconductor Software License Agreement
+LIBFSLPARSER_LICENSE_FILES = EULA EULA.txt
+# This is a legal minefield: the EULA in the bin file specifies that
+# the Board Support Package includes software and hardware (sic!)
+# for which a separate license is needed...
+LIBFSLPARSER_REDISTRIBUTE = NO
+
+LIBFSLPARSER_INSTALL_STAGING = YES
+
+# The archive is a shell-self-extractor of a bzipped tar. It happens
+# to extract in the correct directory (libfslparser-x.y.z)
+# The --force makes sure it doesn't fail if the source dir already exists.
+# The --auto-accept skips the license check - not needed for us
+# because we have legal-info
+# Since the EULA in the bin file differs from the one in the tar file,
+# extract the one from the bin file as well.
+define LIBFSLPARSER_EXTRACT_CMDS
+       awk 'BEGIN      { start=0; } \
+            /^EOEULA/  { start = 0; } \
+                       { if (start) print; } \
+            /<<EOEULA/ { start=1; }'\
+           $(DL_DIR)/$(LIBFSLPARSER_SOURCE) > $(@D)/EULA
+       cd $(BUILD_DIR); \
+       sh $(DL_DIR)/$(LIBFSLPARSER_SOURCE) --force --auto-accept
+endef
+
+# The Makefile installs several versions of the libraries, but we only
+# need one of them, depending on the platform.
+
+$(eval $(autotools-package))