uclibc: use shell script testsuite runner
authorWaldemar Brodkorb <wbx@openadk.org>
Sat, 4 Jun 2016 20:49:32 +0000 (22:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 6 Jun 2016 20:35:52 +0000 (22:35 +0200)
There is no need for GNU make to run the testsuite.
The benefit is you can even try it on noMMU targets as
the script runs with busybox hush.
Parallel build of the testsuite seems to work well.

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/uclibc/Config.in
package/uclibc/uclibc.mk

index f5a33106d00a9fca5cf21ad61a23d30df5c648d2..adcea3820c69aad2224be6de02deded4b8ff6e09 100644 (file)
@@ -98,8 +98,6 @@ config BR2_UCLIBC_INSTALL_UTILS
 
 config BR2_UCLIBC_INSTALL_TEST_SUITE
        bool "Compile and install uClibc tests"
-       select BR2_PACKAGE_MAKE
-       depends on BR2_USE_MMU # make
        help
          Enabling this option will compile and install the uClibc test suite.
          This is useful if you want to check if the uClibc library is working
@@ -107,7 +105,7 @@ config BR2_UCLIBC_INSTALL_TEST_SUITE
 
          The test suite will be installed into /root/uClibc directory. To run
          the test suite enter the /root/uClibc/test directory and type
-         "make UCLIBC_ONLY=1 CC=/bin/true check".
+         "sh uclibcng-testrunner.sh".
 
          See the /root/uClibc/test/README for additional information.
 
index cf343a46de3efa32c9da51508a1a5625f41a3830..e20e8a81785e20508a23f255736ef2b416582cf9 100644 (file)
@@ -444,11 +444,11 @@ endef
 
 ifeq ($(BR2_UCLIBC_INSTALL_TEST_SUITE),y)
 define UCLIBC_BUILD_TEST_SUITE
-       $(MAKE1) -C $(@D) \
+       $(MAKE) -C $(@D) \
                $(UCLIBC_MAKE_FLAGS) \
                TEST_INSTALLED_UCLIBC=1 \
                UCLIBC_ONLY=1 \
-               test_compile
+               test_compile test_gen
 endef
 endif
 
@@ -464,8 +464,7 @@ ifeq ($(BR2_UCLIBC_INSTALL_TEST_SUITE),y)
 define UCLIBC_INSTALL_TEST_SUITE
        mkdir -p $(TARGET_DIR)/root/uClibc
        cp -rdpf $(@D)/test $(TARGET_DIR)/root/uClibc
-       $(INSTALL) -D -m 0644 $(@D)/Rules.mak $(TARGET_DIR)/root/uClibc/Rules.mak
-       $(INSTALL) -D -m 0644 $(@D)/.config $(TARGET_DIR)/root/uClibc/.config
+       find $(TARGET_DIR)/root/uClibc -name \*.o -exec rm {} \;
 endef
 endif