pugixml: new package
authorTheo Debrouwere <t.debrouwere@televic.com>
Wed, 7 Sep 2016 15:37:07 +0000 (17:37 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 7 Sep 2016 19:36:16 +0000 (21:36 +0200)
pugixml is a light-weight C++ XML processing library. It features:
* DOM-like interface with rich traversal/modification capabilities
* Extremely fast non-validating XML parser which constructs the DOM tree from an XML file/buffer
* XPath 1.0 implementation for complex data-driven tree queries
* Full Unicode support with Unicode interface variants and automatic encoding conversions

Homepage: http://pugixml.org/
Repository: https://github.com/zeux/pugixml

Signed-off-by: Theo Debrouwere <t.debrouwere@televic.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/pugixml/Config.in [new file with mode: 0644]
package/pugixml/pugixml.hash [new file with mode: 0644]
package/pugixml/pugixml.mk [new file with mode: 0644]

index add6052c5e4c590d273ac33247f64937f04e3b1e..2b5a4d193a2a911cbbe7949b4ad8c9bc716c7e90 100644 (file)
@@ -1093,6 +1093,7 @@ menu "JSON/XML"
        source "package/libxslt/Config.in"
        source "package/libyaml/Config.in"
        source "package/mxml/Config.in"
+       source "package/pugixml/Config.in"
        source "package/rapidjson/Config.in"
        source "package/rapidxml/Config.in"
        source "package/raptor/Config.in"
diff --git a/package/pugixml/Config.in b/package/pugixml/Config.in
new file mode 100644 (file)
index 0000000..5310b10
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_PUGIXML
+       bool "pugixml"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         Light-weight, simple and fast XML parser for C++ with XPath support
+
+         Features:
+         * DOM-like interface with rich traversal/modification capabilities
+         * Extremely fast non-validating XML parser which constructs the DOM tree
+           from an XML file/buffer
+         * XPath 1.0 implementation for complex data-driven tree queries
+         * Full Unicode support with Unicode interface variants and automatic
+           encoding conversions
+
+         http://pugixml.org/
+         https://github.com/zeux/pugixml
diff --git a/package/pugixml/pugixml.hash b/package/pugixml/pugixml.hash
new file mode 100644 (file)
index 0000000..9007f7c
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256  fbe10d46f61d769f7d92a296102e4e2bd3ee16130f11c5b10a1aae590ea1f5ca  pugixml-1.7.tar.gz
diff --git a/package/pugixml/pugixml.mk b/package/pugixml/pugixml.mk
new file mode 100644 (file)
index 0000000..2e4f0ce
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# pugixml
+#
+################################################################################
+
+PUGIXML_VERSION = 1.7
+PUGIXML_SITE = http://github.com/zeux/pugixml/releases/download/v$(PUGIXML_VERSION)
+PUGIXML_LICENSE = MIT
+PUGIXML_LICENSE_FILES = readme.txt
+PUGIXML_INSTALL_STAGING = YES
+
+PUGIXML_SUBDIR = scripts
+
+$(eval $(cmake-package))