package/beecrypt: Replace work-around to fix gcc-4.7 compile error
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 19 Oct 2014 17:07:57 +0000 (19:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Oct 2014 16:00:56 +0000 (18:00 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/beecrypt/beecrypt-0004-gcc-4.7.patch [new file with mode: 0644]
package/beecrypt/beecrypt.mk

diff --git a/package/beecrypt/beecrypt-0004-gcc-4.7.patch b/package/beecrypt/beecrypt-0004-gcc-4.7.patch
new file mode 100644 (file)
index 0000000..767f789
--- /dev/null
@@ -0,0 +1,19 @@
+Really fixes gcc-4.7 related compile error:
+../../include/beecrypt/c++/util/AbstractSet.h:59:27: error: 'containsAll' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
+
+Downloaded from upstream bugtracker:
+http://sourceforge.net/p/beecrypt/patches/10/
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+
+--- a/include/beecrypt/c++/util/AbstractSet.h
++++ b/include/beecrypt/c++/util/AbstractSet.h
+@@ -56,7 +56,7 @@
+                                       if (c->size() != size())
+                                               return false;
+-                                      return containsAll(*c);
++                                      return this->containsAll(*c);
+                               }
+                               return false;
+                       }
index e9e701b65a92eca6fd76ebbe5b44cdd34d0171eb..7d2ee0839a45cc1c80d0fe1ff243a2b021d0838e 100644 (file)
@@ -11,12 +11,6 @@ BEECRYPT_INSTALL_STAGING = YES
 BEECRYPT_LICENSE = LGPLv2.1+
 BEECRYPT_LICENSE_FILES = COPYING.LIB
 
-# beecrypt contains C++ code that g++ 4.7 doesn't really
-# like. Upstream does not seem to be really active, so workaround this
-# by passing -fpermissive.
-BEECRYPT_CONF_ENV = \
-       CXXFLAGS="$(TARGET_CXXFLAGS) -fpermissive"
-
 BEECRYPT_CONF_OPTS = \
                --disable-expert-mode \
                --without-java \