directfb: remove broken X.org support
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 1 Sep 2015 22:01:06 +0000 (00:01 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 10 Sep 2015 11:52:46 +0000 (13:52 +0200)
The BR2_PACKAGE_XSERVER option never existed, so it was never possible
for DirectFB to pass --enable-x11. Moreover, doing this without having
at least some dependency on certain X libraries will clearly not work.

Consequently, let's remove this bogus X.org support, and disable X11
support unconditionally (until someone is interested enough to bring
this back to life).

The option was actually named BR2_PACKAGE_DIRECTFB_XSERVER but was not
used by the .mk file.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/directfb/Config.in
package/directfb/directfb.mk

index 3ab40f98dceba049293d297f737f6b27824c9079..98acec5f04428b413661b55680bd308aad4a912b 100644 (file)
@@ -45,10 +45,6 @@ config BR2_PACKAGE_DIRECTFB_TRACE
        help
          Enable call tracing for DirectFB applications
 
-config BR2_PACKAGE_DIRECTFB_XSERVER
-       bool "build with X server backend"
-       depends on BR2_PACKAGE_XORG7
-
 config BR2_PACKAGE_DIRECTFB_UNIQUE
        bool "enable unique window manager"
        depends on BR2_UNIMPLEMENTED
index da12acba2c25e5dd1a35f4dc0e1e7aade43dc7b5..acb3e3addd79c73732b0e837ef2b648d49a7ac8f 100644 (file)
@@ -22,7 +22,8 @@ DIRECTFB_CONF_OPTS = \
        --disable-osx \
        --disable-video4linux \
        --disable-video4linux2 \
-       --without-tools
+       --without-tools \
+       --disable-x11
 
 ifeq ($(BR2_STATIC_LIBS),y)
 DIRECTFB_CONF_OPTS += --disable-dynload
@@ -52,12 +53,6 @@ ifeq ($(BR2_PACKAGE_DIRECTFB_TRACE),y)
 DIRECTFB_CONF_OPTS += --enable-trace
 endif
 
-ifeq ($(BR2_PACKAGE_XSERVER),y)
-DIRECTFB_CONF_OPTS += --enable-x11
-else
-DIRECTFB_CONF_OPTS += --disable-x11
-endif
-
 ifeq ($(BR2_PACKAGE_DIRECTFB_UNIQUE),y)
 DIRECTFB_CONF_OPTS += --enable-unique
 else