liblo: disable werror to fix build issues
authorAlex Baldwin <alexbaldwinmusic@gmail.com>
Sun, 25 Feb 2018 14:40:33 +0000 (15:40 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 25 Feb 2018 20:54:47 +0000 (21:54 +0100)
Pass the --disable-werror option to remove -Werror, and therefore
avoid a number of build failures.

Fixes:

  http://autobuild.buildroot.net/results/61ab7e23d2ef62f055efc74a998e3c108a3cdb43

Signed-off-by: Alex Baldwin <alexbaldwinmusic@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/liblo/liblo.mk

index 14b05279669df2a53309ddefbe2092235093535b..c7d163dae230438227e1f16e76a2875f26825e65 100644 (file)
@@ -12,6 +12,9 @@ LIBLO_LICENSE_FILES = COPYING
 LIBLO_INSTALL_STAGING = YES
 
 # IPv6 support broken, issue known upstream
-LIBLO_CONF_OPTS = --disable-ipv6
+# werror - not needed for release.
+LIBLO_CONF_OPTS += \
+       --disable-ipv6 \
+       --disable-werror
 
 $(eval $(autotools-package))