links: bump to version 2.3pre1
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 9 Feb 2011 18:22:40 +0000 (15:22 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 9 Feb 2011 21:59:53 +0000 (22:59 +0100)
* Switch to links 2.3pre1.
* Enable graphics mode via directfb.

TODO: Support X11 mode, maybe linuxfb (requires gpm).

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/links/Config.in
package/links/links-1.01pre1-no-ssl-largefile.patch [deleted file]
package/links/links-no-largefile.patch [new file with mode: 0644]
package/links/links.mk

index 5a0ce9c665fd02a8bf817280928d1279dc62b8cc..fddf3d26027027cd3c6ffc995b0996ee0f2f249c 100644 (file)
@@ -3,4 +3,13 @@ config BR2_PACKAGE_LINKS
        help
          Graphics and text mode WWW browser (kind of like lynx).
 
-         http://atrey.karlin.mff.cuni.cz/~clock/twibright/links
+         http://links.twibright.com/
+
+config BR2_PACKAGE_LINKS_GRAPHICS
+       bool "use graphics (directfb)"
+       depends on BR2_PACKAGE_LINKS
+       select BR2_PACKAGE_DIRECTFB
+       select BR2_PACKAGE_LIBPNG
+       help
+         Enable graphics output.
+         Otherwise links will be text-mode only.
diff --git a/package/links/links-1.01pre1-no-ssl-largefile.patch b/package/links/links-1.01pre1-no-ssl-largefile.patch
deleted file mode 100644 (file)
index f3143cb..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: links-1.01pre1-no-ssl/links.h
-===================================================================
---- links-1.01pre1-no-ssl.orig/links.h 2010-06-21 00:39:10.000000000 +0200
-+++ links-1.01pre1-no-ssl/links.h      2010-06-21 00:39:52.000000000 +0200
-@@ -2,6 +2,9 @@
- #define __EXTENSIONS__
- #endif
-+#include <features.h>
-+/* uclibc without largefile support #errors on _FILE_OFFSET_BITS=64 */
-+#if !(defined(__UCLIBC__) && !defined(__UCLIBC_HAS_LFS__))
- #ifndef _LARGEFILE_SOURCE
- #define _LARGEFILE_SOURCE     1
- #endif
-@@ -9,6 +12,7 @@
- #ifndef _FILE_OFFSET_BITS
- #define _FILE_OFFSET_BITS     64
- #endif
-+#endif
- #ifdef HAVE_CONFIG_H
- #include "config.h"
diff --git a/package/links/links-no-largefile.patch b/package/links/links-no-largefile.patch
new file mode 100644 (file)
index 0000000..f3143cb
--- /dev/null
@@ -0,0 +1,22 @@
+Index: links-1.01pre1-no-ssl/links.h
+===================================================================
+--- links-1.01pre1-no-ssl.orig/links.h 2010-06-21 00:39:10.000000000 +0200
++++ links-1.01pre1-no-ssl/links.h      2010-06-21 00:39:52.000000000 +0200
+@@ -2,6 +2,9 @@
+ #define __EXTENSIONS__
+ #endif
++#include <features.h>
++/* uclibc without largefile support #errors on _FILE_OFFSET_BITS=64 */
++#if !(defined(__UCLIBC__) && !defined(__UCLIBC_HAS_LFS__))
+ #ifndef _LARGEFILE_SOURCE
+ #define _LARGEFILE_SOURCE     1
+ #endif
+@@ -9,6 +12,7 @@
+ #ifndef _FILE_OFFSET_BITS
+ #define _FILE_OFFSET_BITS     64
+ #endif
++#endif
+ #ifdef HAVE_CONFIG_H
+ #include "config.h"
index 2e17066f23b3519b303e6c39df0e2fc0e9acd2e9..b8520d4a04740f93e7fed20bbccc36751ea24d50 100644 (file)
@@ -1,16 +1,35 @@
 #############################################################
 #
-# links (text based web browser)
+# links
 #
 #############################################################
-LINKS_VERSION:=1.01pre1-no-ssl
-LINKS_SITE:=http://artax.karlin.mff.cuni.cz/~mikulas/vyplody/links/download/no-ssl
-LINKS_SOURCE:=links-$(LINKS_VERSION).tar.gz
 
-LINKS_CONF_OPT = --localstatedir=/tmp
+LINKS_VERSION = 2.3pre1
+LINKS_SITE = http://links.twibright.com/download
+LINKS_CONF_OPT = --without-x
 
-define LINKS_INSTALL_TARGET_CMDS
-       install -c $(@D)/links $(TARGET_DIR)/usr/bin/links
-endef
+ifeq ($(BR2_PACKAGE_LINKS_GRAPHICS),y)
+LINKS_CONF_OPT += --enable-graphics
+LINKS_CONF_ENV = ac_cv_path_DIRECTFB_CONFIG=$(STAGING_DIR)/usr/bin/directfb-config
+LINKS_DEPENDENCIES += directfb libpng
+ifeq ($(BR2_PACKAGE_JPEG),y)
+LINKS_DEPENDENCIES += jpeg
+endif
+ifeq ($(BR2_PACKAGE_TIFF),y)
+LINKS_DEPENDENCIES += tiff
+endif
+endif
+
+ifeq ($(BR2_PACKAGE_BZIP2),y)
+LINKS_DEPENDENCIES += bzip2
+endif
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+LINKS_DEPENDENCIES += openssl
+endif
+
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+LINKS_DEPENDENCIES += zlib
+endif
 
 $(eval $(call AUTOTARGETS,package,links))