elf2flt: fix after conversion of binutils to package infrastructure
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 18 Mar 2012 15:35:58 +0000 (16:35 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 18 Mar 2012 19:47:46 +0000 (20:47 +0100)
When binutils was converted to the package infrastructure (commit
009407e6b), the variable that elf2flt uses to find the binutils
libraries disappeared.  So use HOST_BINUTILS_DIR instead of
BINUTILS_DIR1.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/elf2flt/elf2flt.mk

index e74a6553bf2dfa60c4a8cf13e01078e1387e5018..84a2c0119ef829dc0426592ad58f726515190e51 100644 (file)
@@ -21,12 +21,12 @@ $(ELF2FLT_DIR)/.configured: $(ELF2FLT_DIR)/.patched
        (cd $(ELF2FLT_DIR); rm -rf config.cache; \
                LDFLAGS=-lz \
                $(ELF2FLT_DIR)/configure $(QUIET) \
-               --with-bfd-include-dir=$(BINUTILS_DIR1)/bfd/ \
-               --with-binutils-include-dir=$(BINUTILS_DIR)/include/ \
+               --with-bfd-include-dir=$(HOST_BINUTILS_DIR)/bfd/ \
+               --with-binutils-include-dir=$(HOST_BINUTILS_DIR)/include/ \
                --target=$(REAL_GNU_TARGET_NAME) \
-               --with-libbfd=$(BINUTILS_DIR1)/bfd/libbfd.a \
-               --with-libiberty=$(BINUTILS_DIR1)/libiberty/libiberty.a \
-               --prefix=$(STAGING_DIR)/usr)
+               --with-libbfd=$(HOST_BINUTILS_DIR)/bfd/libbfd.a \
+               --with-libiberty=$(HOST_BINUTILS_DIR)/libiberty/libiberty.a \
+               --prefix=$(HOST_DIR)/usr)
        touch $@
 
 $(ELF2FLT_DIR)/$(ELF2FLT_BINARY): $(ELF2FLT_DIR)/.configured