Makefile: help: BR2_DEFCONFIG for defconfig must be on command line
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 22 Jul 2018 21:34:45 +0000 (23:34 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 28 Jul 2018 21:21:14 +0000 (23:21 +0200)
The help text says that BR2_DEFCONFIG will be used as input, but a
BR2_DEFCONFIG specified in the existing .config file will *not* be
used. So say explicitly that it must be specified on the command line.
Note that both "BR2_DEFCONFIG=... make defconfig" and
"make defconfig BR2_DEFCONFIG=..." will work.

While we're at it, add a semicolon to separate the two statements.

Note that this overflows the help text beyond 80 characters, but that
is already the case in many other lines.

Reported-by: Anisse Astier <anisse@astier.eu>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Makefile

index 8d25c8a23983ba10d3d76c7b707f12584c5fb268..37c7072c7c288a1696b4c11aeb7fc6c62957dbeb 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1020,8 +1020,8 @@ help:
        @echo '  silentoldconfig        - Same as oldconfig, but quietly, additionally update deps'
        @echo '  olddefconfig           - Same as silentoldconfig but sets new symbols to their default value'
        @echo '  randconfig             - New config with random answer to all options'
-       @echo '  defconfig              - New config with default answer to all options'
-       @echo '                             BR2_DEFCONFIG, if set, is used as input'
+       @echo '  defconfig              - New config with default answer to all options;'
+       @echo '                             BR2_DEFCONFIG, if set on the command line, is used as input'
        @echo '  savedefconfig          - Save current config to BR2_DEFCONFIG (minimal config)'
        @echo '  allyesconfig           - New config where all options are accepted with yes'
        @echo '  allnoconfig            - New config where all options are answered with no'