package/heirloom-mailx: fix build failure due to gcc bug 101916
authorGiulio Benetti <giulio.benetti@benettiengineering.com>
Sat, 14 Aug 2021 22:58:03 +0000 (00:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 19 Aug 2021 20:58:06 +0000 (22:58 +0200)
The heirloom-mailx package exhibits gcc bug 101916 when built for the
SH4 architecture with optimization enabled, which causes a build failure.

As done for other packages in Buildroot work around this gcc bug by
setting optimization to -O0 if BR2_TOOLCHAIN_HAS_GCC_BUG_101916=y.
Also introduce HEIRLOOM_MAILX_CFLAGS as done for other packages and move
the already present -fPIC CFLAG to it.

Fixes:
http://autobuild.buildroot.net/results/911/911f5c024834741754102ff1bbb05c4a64c54a0b/

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/heirloom-mailx/heirloom-mailx.mk

index b3cece0cfc9e8257fa4f8343becb7161eae404b0..e851e1dfcc2c12d1f553eb2a402b9d5a7da5a033 100644 (file)
@@ -20,10 +20,18 @@ define HEIRLOOM_MAILX_CONFIGURE_CMDS
        (cd $(@D); $(TARGET_CONFIGURE_OPTS) $(SHELL) ./makeconfig)
 endef
 
+HEIRLOOM_MAILX_CFLAGS = $(TARGET_CFLAGS)
+
 # -fPIC is needed to build with NIOS2 toolchains.
+HEIRLOOM_MAILX_CFLAGS += -fPIC
+
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_101916),y)
+HEIRLOOM_MAILX_CFLAGS += -O0
+endif
+
 define HEIRLOOM_MAILX_BUILD_CMDS
        $(TARGET_CONFIGURE_OPTS) $(MAKE) \
-               CFLAGS="$(TARGET_CFLAGS) -fPIC" \
+               CFLAGS="$(HEIRLOOM_MAILX_CFLAGS)" \
                -C $(@D)
 endef