xz: revert back to using a .bz2 archive
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 7 Jan 2015 08:31:42 +0000 (09:31 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 7 Jan 2015 08:31:42 +0000 (09:31 +0100)
On machines where xzcat/unxz is not available, we build host-xz. So if
host-xz is itself downloaded as a xz-compressed archive, it doesn't
work. Revert back to a .bz2 archive.

Fixes:

  http://autobuild.buildroot.org/results/79e/79ecba46f353546ba60ae86dd3898b4d86c056a0/
  (and many similar failures)

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xz/xz.mk

index 1b44678375e02d8375d62ee9521dd244db1e63ee..24b1adb9d924c402e528fb19fa12b5ad42ee9863 100644 (file)
@@ -5,7 +5,7 @@
 ################################################################################
 
 XZ_VERSION = 5.2.0
-XZ_SOURCE = xz-$(XZ_VERSION).tar.xz
+XZ_SOURCE = xz-$(XZ_VERSION).tar.bz2
 XZ_SITE = http://tukaani.org/xz
 XZ_INSTALL_STAGING = YES
 XZ_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'