pkg-python: improve error handling
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 15 Dec 2013 15:17:28 +0000 (16:17 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 15 Dec 2013 15:21:19 +0000 (16:21 +0100)
Make the python packing a bit easier to use by providing a detailed error
message if <pkg>_SETUP_TYPE isn't set to a valid value.

At the same time adjust the error message used when <pkg>_SETUP_TIME isn't
set to list the exact variable name that should be set, and don't talk about
'Unknown' as it isn't printed when the variable isn't set (or is set to the
empty string).

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-python.mk

index e436f22aaa1ab3866c34c02820c8bc6756700e4a..5f137d58f95b6f7575e32730799e6ec3bc9c83a8 100644 (file)
@@ -94,7 +94,7 @@ ifndef $(2)_SETUP_TYPE
  ifdef $(3)_SETUP_TYPE
   $(2)_SETUP_TYPE = $($(3)_SETUP_TYPE)
  else
-  $$(error "$(1): Unknown or undefined <pkg>_SETUP_TYPE")
+  $$(error "$(2)_SETUP_TYPE must be set")
  endif
 endif
 
@@ -124,6 +124,8 @@ $(2)_BASE_BUILD_TGT   = build
 $(2)_BASE_BUILD_OPT   =
 $(2)_BASE_INSTALL_OPT = $$(HOST_PKG_PYTHON_SETUPTOOLS_INSTALL_OPT)
 endif
+else
+$$(error "Invalid $(2)_SETUP_TYPE. Valid options are 'distutils' or 'setuptools'")
 endif
 
 # The below statement intends to calculate the dependencies of host