package/gstreamer1/gst1-plugins-good: fix xlib dependencies
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 16 Oct 2019 16:55:12 +0000 (18:55 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 16 Oct 2019 19:55:51 +0000 (21:55 +0200)
xlib_libXfixes and xlib_libXdamage must be added to dependencies

Fixes:
 - http://autobuild.buildroot.org/results/efc1052807f94b1013cc8c13bdd790a01ed7255d

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gstreamer1/gst1-plugins-good/gst1-plugins-good.mk

index a8dae1b7bbca2c87fe16e11722c770de8c7c946c..e11f9c213e6d14e95adbd1f214691664fb810b22 100644 (file)
@@ -366,10 +366,15 @@ endif
 
 ifeq ($(BR2_PACKAGE_XORG7),y)
 GST1_PLUGINS_GOOD_DEPENDENCIES += xlib_libX11 xlib_libXext xlib_libXv
-GST1_PLUGINS_GOOD_CONF_OPTS += \
-       -Dximagesrc=enabled \
-       $(if $(BR2_PACKAGE_XLIB_LIBXFIXES),-Dximagesrc-xfixes=enabled) \
-       $(if $(BR2_PACKAGE_XLIB_LIBXDAMAGE),-Dximagesrc-xdamage=enabled)
+GST1_PLUGINS_GOOD_CONF_OPTS += -Dximagesrc=enabled
+ifeq ($(BR2_PACKAGE_XLIB_LIBXFIXES),y)
+GST1_PLUGINS_GOOD_DEPENDENCIES += xlib_libXfixes
+GST1_PLUGINS_GOOD_CONF_OPTS += -Dximagesrc-xfixes=enabled
+endif
+ifeq ($(BR2_PACKAGE_XLIB_LIBXDAMAGE),y)
+GST1_PLUGINS_GOOD_DEPENDENCIES += xlib_libXdamage
+GST1_PLUGINS_GOOD_CONF_OPTS += -Dximagesrc-xdamage=enabled
+endif
 else
 GST1_PLUGINS_GOOD_CONF_OPTS += \
        -Dximagesrc=disabled \