fetchmail: adjust zlib handling
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 19 May 2017 21:04:41 +0000 (23:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 31 May 2017 21:04:53 +0000 (23:04 +0200)
fetchmail itself does not need zlib, there is no reference to it in its
source, so the "select BR2_PACKAGE_ZLIB" is not necessary. Moreover,
"zlib" was not added to FETCHMAIL_DEPENDENCIES (but was anyway in the
dependency chain through openssl).

In addition, LIBS="-lz" is only needed in static linking configurations,
to help fetchmail's configure script find OpenSSL (it doesn't use
pkg-config unfortunately).

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/fetchmail/Config.in
package/fetchmail/fetchmail.mk

index 7c14176b236a56cad60ee49b5b284ea01307cef4..62f4f84d502cc8d74f9580f69045075d4886e4d9 100644 (file)
@@ -3,7 +3,6 @@ config BR2_PACKAGE_FETCHMAIL
        depends on BR2_USE_MMU # fork()
        select BR2_PACKAGE_CA_CERTIFICATES
        select BR2_PACKAGE_OPENSSL
-       select BR2_PACKAGE_ZLIB
        help
          Fetchmail - the mail-retrieval daemon
          Client daemon to move mail from POP and IMAP to your local computer
index 49ce0d3a80f4597328addfee13080ba2ab4e2600..164b2f8ad836251fdfec1643a4b67e5c469f0ccf 100644 (file)
@@ -13,7 +13,11 @@ FETCHMAIL_LICENSE_FILES = COPYING
 FETCHMAIL_AUTORECONF = YES
 FETCHMAIL_GETTEXTIZE = YES
 
+# needed to help fetchmail detecting the availability of openssl,
+# because it doesn't use pkg-config
+ifeq ($(BR2_STATIC_LIBS),y)
 FETCHMAIL_CONF_ENV += LIBS="-lz"
+endif
 
 FETCHMAIL_CONF_OPTS = \
        --with-ssl=$(STAGING_DIR)/usr