checkpolicy: rework host installation
authorArnout Vandecappelle <arnout@mind.be>
Wed, 5 Jul 2017 11:14:51 +0000 (13:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 5 Jul 2017 14:06:52 +0000 (16:06 +0200)
checkpolicy has a pretty peculiar interpretation of DESTDIR and PREFIX.
PREFIX simply defaults to $(DESTDIR)/usr, and is used in the rest of
the build system. DESTDIR isn't used any further.

For the host installation, we don't want the usr part, so set PREFIX
instead of DESTDIR.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/checkpolicy/checkpolicy.mk

index d80bb792b4288424fd395f36e6454760ee08b901..f0cca593d35f465f7b151ae12dbce54596b8cdd1 100644 (file)
@@ -31,17 +31,19 @@ endef
 
 HOST_CHECKPOLICY_DEPENDENCIES = host-libselinux host-flex host-bison
 
-HOST_CHECKPOLICY_MAKE_OPTS = $(HOST_CONFIGURE_OPTS) \
+# PREFIX is used at build time to find host-libselinux
+HOST_CHECKPOLICY_MAKE_OPTS = \
+       $(HOST_CONFIGURE_OPTS) \
+       PREFIX=$(HOST_DIR) \
        LEX="$(HOST_DIR)/bin/flex" \
        YACC="$(HOST_DIR)/bin/bison -y"
 
-# DESTDIR is used at build time to find host-libselinux
 define HOST_CHECKPOLICY_BUILD_CMDS
-       $(HOST_MAKE_ENV) $(MAKE) -C $(@D) $(HOST_CHECKPOLICY_MAKE_OPTS) DESTDIR=$(HOST_DIR)
+       $(HOST_MAKE_ENV) $(MAKE) -C $(@D) $(HOST_CHECKPOLICY_MAKE_OPTS)
 endef
 
 define HOST_CHECKPOLICY_INSTALL_CMDS
-       $(HOST_MAKE_ENV) $(MAKE) -C $(@D) $(HOST_CHECKPOLICY_MAKE_OPTS) DESTDIR=$(HOST_DIR) install
+       $(HOST_MAKE_ENV) $(MAKE) -C $(@D) $(HOST_CHECKPOLICY_MAKE_OPTS) install
 endef
 
 $(eval $(generic-package))