pkg-infra: move the cp (aka localfiles) download helper to a script
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 2 Jul 2014 21:11:26 +0000 (23:11 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 2 Jul 2014 22:07:57 +0000 (00:07 +0200)
Maintaining the download helpers in the Makefile has proved to be a bit
complex, so move it to a shell script.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-download.mk
support/download/cp [new file with mode: 0755]

index eec91b86657f161ac308b2baf63382142db23beb..d3cd0c144e286b19d74d9435378532875dc22652 100644 (file)
@@ -16,7 +16,7 @@ export GIT := $(call qstrip,$(BR2_GIT))
 export HG := $(call qstrip,$(BR2_HG)) $(QUIET)
 export SCP := $(call qstrip,$(BR2_SCP)) $(QUIET)
 SSH := $(call qstrip,$(BR2_SSH)) $(QUIET)
-LOCALFILES := $(call qstrip,$(BR2_LOCALFILES))
+export LOCALFILES := $(call qstrip,$(BR2_LOCALFILES))
 
 # Default spider mode is 'DOWNLOAD'. Other possible values are 'SOURCE_CHECK'
 # used by the _source-check target and 'SHOW_EXTERNAL_DEPS', used by the
@@ -192,7 +192,8 @@ endef
 
 define DOWNLOAD_LOCALFILES
        test -e $(DL_DIR)/$(2) || \
-               $(LOCALFILES) $(call stripurischeme,$(call qstrip,$(1))) $(DL_DIR)
+       $(EXTRA_ENV) support/download/cp $(call stripurischeme,$(call qstrip,$(1))) \
+                                        $(DL_DIR)
 endef
 
 define SOURCE_CHECK_LOCALFILES
diff --git a/support/download/cp b/support/download/cp
new file mode 100755 (executable)
index 0000000..3e9f548
--- /dev/null
@@ -0,0 +1,16 @@
+#!/bin/bash
+
+# We want to catch any command failure, and exit immediately
+set -e
+
+# Download helper for cp
+# Call it with:
+#   $1: source file
+#   $2: output file
+# And this environment:
+#   LOCALFILES: the cp command to call
+
+source="${1}"
+output="${2}"
+
+${LOCALFILES} "${source}" "${output}"