efibootmgr: explicitly depend on host-pkgconf and popt
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 23 Mar 2018 09:57:40 +0000 (10:57 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 23 Mar 2018 15:28:46 +0000 (16:28 +0100)
efibootmgr uses host-pkgconf and popt, so explicitly add them to
_DEPENDENCIES instead of relying on them getting pulled in by efivar.

[Peter: reword as suggested by Thomas]
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/efibootmgr/Config.in
package/efibootmgr/efibootmgr.mk

index 492ebe6e6ec638971083560eb4a3c7647cf3a60f..b87fb53225586b657dce303ce604fab668a4b715 100644 (file)
@@ -7,6 +7,7 @@ config BR2_PACKAGE_EFIBOOTMGR
        depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # efivar
        depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS
        select BR2_PACKAGE_EFIVAR
+       select BR2_PACKAGE_POPT
        help
          A Linux user-space application to modify the Intel Extensible
          Firmware Interface (EFI) Boot Manager. This application can
index cdd500f088e9eddb650334c3288222307be37f53..bdc0019d993c8509bb5b001896407f5dec97c925 100644 (file)
@@ -8,7 +8,7 @@ EFIBOOTMGR_VERSION = 15
 EFIBOOTMGR_SITE = $(call github,rhboot,efibootmgr,$(EFIBOOTMGR_VERSION))
 EFIBOOTMGR_LICENSE = GPL-2.0+
 EFIBOOTMGR_LICENSE_FILES = COPYING
-EFIBOOTMGR_DEPENDENCIES = efivar $(TARGET_NLS_DEPENDENCIES)
+EFIBOOTMGR_DEPENDENCIES = host-pkgconf efivar popt $(TARGET_NLS_DEPENDENCIES)
 EFIBOOTMGR_LDFLAGS = $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)
 EFIBOOTMGR_MAKE_ARGS = EFIDIR=buildroot