genext2fs: bump to 1.4.1
authorMartin Banky <martin.banky@gmail.com>
Sun, 19 Sep 2010 02:53:30 +0000 (19:53 -0700)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 6 Oct 2010 11:38:46 +0000 (13:38 +0200)
Signed-off-by: Martin Banky <Martin.Banky@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/genext2fs/genext2fs-1.4-nosquash.patch [deleted file]
package/genext2fs/genext2fs-1.4-remove_ugly_warnings.patch [deleted file]
package/genext2fs/genext2fs-1.4.1-nosquash.patch [new file with mode: 0644]
package/genext2fs/genext2fs-1.4.1-remove_ugly_warnings.patch [new file with mode: 0644]
package/genext2fs/genext2fs.mk

diff --git a/CHANGES b/CHANGES
index 1f80097a3e52ef7d77b59834502d6fff455e72ec..c2ab972a29ff44d0e8dec9a0b295aef3d66fa1bd 100644 (file)
--- a/CHANGES
+++ b/CHANGES
        automake, avahi, axel, beecrypt, berkeleydb, bind, bmon, boa,
        bootutils, bridge-utils, bsdiff, busybox, cvs, dbus, dmraid,
        docker, dosfstools, dropbear, e2fsprogs, expat, ezxml, fbset,
-       fconfig, ffmpeg, freetype, gadgetfs-test, gamin, gawk, gperf,
-       gst-plugins-ugly, gtk2-themes, gtkperf, gvfs, haserl, hdparm,
-       hostapd, hwdata, ifplugd, imagemagick, iperf, ipsec-tools,
-       iproute2, iptables, iw, jpeg, kexec, kismet, less, libcgi,
-       libcurl, libdaemon, libdnet, liberation, libevent, libeXosip2,
-       libglade, libgtk2, libiconv, libidn, libintl, libmms, libnl,
-       liboil, libosip2, libpcap, libpng, libtool, libungif, libxml2,
-       libxslt, lighttpd, lite, lm-sensors, lockfile-progs,
-       logrotate, m4, mdadm, mesa3d, metacity, mtd-utils,
-       mysql_client, nano, nbd, ncftp, neon, netperf, netsnmp,
-       ng-spice-rework, ntfsprogs, ntp, openntpd, openssh, openvpn,
-       oprofile, pango, patch, pcre, php, pkg-config, prboom, radvd,
-       rdesktop, ruby, qt, quagga, samba, sawman, sdl_mixer,
-       sdl_sound, setserial, shared-mime-info, speex, sqlite,
-       squashfs, strace, sylpheed, taglib, tcpdump, thttpd, tiff,
-       tn5250, udev, udpcast, usbmount, usbutils, vsftpd, vtun,
-       which, wpa_supplicant, xapp_twm, xapp_xbacklight,
+       fconfig, ffmpeg, freetype, gadgetfs-test, gamin, gawk,
+       genext2fs, gperf, gst-plugins-ugly, gtk2-themes, gtkperf,
+       gvfs, haserl, hdparm, hostapd, hwdata, ifplugd, imagemagick,
+       iperf, ipsec-tools, iproute2, iptables, iw, jpeg, kexec,
+       kismet, less, libcgi, libcurl, libdaemon, libdnet, liberation,
+       libevent, libeXosip2, libglade, libgtk2, libiconv, libidn,
+       libintl, libmms, libnl, liboil, libosip2, libpcap, libpng,
+       libtool, libungif, libxml2, libxslt, lighttpd, lite,
+       lm-sensors, lockfile-progs, logrotate, m4, mdadm, mesa3d,
+       metacity, mtd-utils, mysql_client, nano, nbd, ncftp, neon,
+       netperf, netsnmp, ng-spice-rework, ntfsprogs, ntp, openntpd,
+       openssh, openvpn, oprofile, pango, patch, pcre, php,
+       pkg-config, prboom, radvd, rdesktop, ruby, qt, quagga, samba,
+       sawman, sdl_mixer, sdl_sound, setserial, shared-mime-info,
+       speex, sqlite, squashfs, strace, sylpheed, taglib, tcpdump,
+       thttpd, tiff, tn5250, udev, udpcast, usbmount, usbutils,
+       vsftpd, vtun, which, wpa_supplicant, xapp_twm,
+       xapp_xbacklight,
        xdriver_xf86-input-{acecad,aiptek,evdev,joystick,keyboard},
        xdriver-xf86-input-{mouse,synaptics,vmmouse,void},
        xdriver-xf86-video-{apm,ark,ast,ati,chips,cirrus,dummy,fbdev},
diff --git a/package/genext2fs/genext2fs-1.4-nosquash.patch b/package/genext2fs/genext2fs-1.4-nosquash.patch
deleted file mode 100644 (file)
index 236dfcc..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ru genext2fs-1.4/genext2fs.c genext2fs-1.4-nosquash/genext2fs.c
---- genext2fs-1.4/genext2fs.c  2006-12-19 17:45:31.000000000 +0100
-+++ genext2fs-1.4-nosquash/genext2fs.c 2007-02-09 10:47:05.000000000 +0100
-@@ -1629,10 +1629,6 @@
-               mtime = st.st_mtime;
-               name = dent->d_name;
-               mode = get_mode(&st);
--              if(squash_uids)
--                      uid = gid = 0;
--              if(squash_perms)
--                      mode &= ~(FM_IRWXG | FM_IRWXO);
-               if(stats)
-                       switch(st.st_mode & S_IFMT)
-                       {
diff --git a/package/genext2fs/genext2fs-1.4-remove_ugly_warnings.patch b/package/genext2fs/genext2fs-1.4-remove_ugly_warnings.patch
deleted file mode 100644 (file)
index ef23dfb..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ru genext2fs-1.4/genext2fs.c genext2fs-1.4-remove_ugly_warnings/genext2fs.c
---- genext2fs-1.4/genext2fs.c  2007-02-09 10:54:56.000000000 +0100
-+++ genext2fs-1.4-remove_ugly_warnings/genext2fs.c     2007-02-09 10:54:30.000000000 +0100
-@@ -1606,7 +1606,7 @@
- static void
- add2fs_from_dir(filesystem *fs, uint32 this_nod, int squash_uids, int squash_perms, uint32 fs_timestamp, struct stats *stats)
- {
--      uint32 nod;
-+      uint32 nod = 0;
-       uint32 uid, gid, mode, ctime, mtime;
-       const char *name;
-       FILE *fh;
-@@ -2056,7 +2056,7 @@
- static filesystem *
- load_fs(FILE * fh, int swapit)
- {
--      size_t fssize;
-+      size_t fssize = 0;
-       filesystem *fs;
-       if((fseek(fh, 0, SEEK_END) < 0) || ((ssize_t)(fssize = ftell(fh)) == -1))
-               perror_msg_and_die("input filesystem image");
diff --git a/package/genext2fs/genext2fs-1.4.1-nosquash.patch b/package/genext2fs/genext2fs-1.4.1-nosquash.patch
new file mode 100644 (file)
index 0000000..236dfcc
--- /dev/null
@@ -0,0 +1,14 @@
+diff -ru genext2fs-1.4/genext2fs.c genext2fs-1.4-nosquash/genext2fs.c
+--- genext2fs-1.4/genext2fs.c  2006-12-19 17:45:31.000000000 +0100
++++ genext2fs-1.4-nosquash/genext2fs.c 2007-02-09 10:47:05.000000000 +0100
+@@ -1629,10 +1629,6 @@
+               mtime = st.st_mtime;
+               name = dent->d_name;
+               mode = get_mode(&st);
+-              if(squash_uids)
+-                      uid = gid = 0;
+-              if(squash_perms)
+-                      mode &= ~(FM_IRWXG | FM_IRWXO);
+               if(stats)
+                       switch(st.st_mode & S_IFMT)
+                       {
diff --git a/package/genext2fs/genext2fs-1.4.1-remove_ugly_warnings.patch b/package/genext2fs/genext2fs-1.4.1-remove_ugly_warnings.patch
new file mode 100644 (file)
index 0000000..ef23dfb
--- /dev/null
@@ -0,0 +1,21 @@
+diff -ru genext2fs-1.4/genext2fs.c genext2fs-1.4-remove_ugly_warnings/genext2fs.c
+--- genext2fs-1.4/genext2fs.c  2007-02-09 10:54:56.000000000 +0100
++++ genext2fs-1.4-remove_ugly_warnings/genext2fs.c     2007-02-09 10:54:30.000000000 +0100
+@@ -1606,7 +1606,7 @@
+ static void
+ add2fs_from_dir(filesystem *fs, uint32 this_nod, int squash_uids, int squash_perms, uint32 fs_timestamp, struct stats *stats)
+ {
+-      uint32 nod;
++      uint32 nod = 0;
+       uint32 uid, gid, mode, ctime, mtime;
+       const char *name;
+       FILE *fh;
+@@ -2056,7 +2056,7 @@
+ static filesystem *
+ load_fs(FILE * fh, int swapit)
+ {
+-      size_t fssize;
++      size_t fssize = 0;
+       filesystem *fs;
+       if((fseek(fh, 0, SEEK_END) < 0) || ((ssize_t)(fssize = ftell(fh)) == -1))
+               perror_msg_and_die("input filesystem image");
index 8c4981edbf7ded63b03e9768e662295a9d3b90e9..b4a8e70c8fa8cb6805734dcf5bd65b6614f32b16 100644 (file)
@@ -4,7 +4,7 @@
 #
 #############################################################
 
-GENEXT2FS_VERSION=1.4
+GENEXT2FS_VERSION=1.4.1
 GENEXT2FS_SOURCE=genext2fs-$(GENEXT2FS_VERSION).tar.gz
 GENEXT2FS_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/genext2fs