package/mono: needs host-python3
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 24 Jul 2021 12:21:22 +0000 (14:21 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 24 Jul 2021 20:09:56 +0000 (22:09 +0200)
host-python3 is needed to avoid the following build failure since bump
to version 6.12.0.90 in commit 4be06fa8aa054e59d97866dc5568f4e10762e353
and
https://github.com/mono/mono/commit/0f47ea5d8088ede472650da47bf58e5a0e063ad4:

checking for a Python interpreter with version >= 3.2... none
configure: error: no suitable Python interpreter found

Fixes:
 - http://autobuild.buildroot.org/results/6a185e69fe8e123ba26c26b69091d001656693c7

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/mono/mono.mk

index df3481a4988bd044f79ef9d343e25cae88d7a0c2..27f7886224ffc17eaf91712342f88aa56f05f245 100644 (file)
@@ -53,7 +53,7 @@ HOST_MONO_CONF_OPTS = $(MONO_COMMON_CONF_OPTS) --disable-libraries
 # ensure monolite is used
 HOST_MONO_MAKE_OPTS += EXTERNAL_MCS=false
 
-HOST_MONO_DEPENDENCIES = host-monolite host-gettext
+HOST_MONO_DEPENDENCIES = host-monolite host-gettext host-python3
 
 define HOST_MONO_SETUP_MONOLITE
        rm -rf $(@D)/mcs/class/lib/monolite