package/{mesa3d, mesa3d-headers}: bump version to 20.1.3
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 10 Jul 2020 05:15:21 +0000 (07:15 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 11 Jul 2020 13:26:21 +0000 (15:26 +0200)
Renumbered patches, rebased patch 0003.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mesa3d-headers/mesa3d-headers.mk
package/mesa3d/0002-c99_math-import-isinf-for-uclibc-based-toolchains.patch [new file with mode: 0644]
package/mesa3d/0003-c99_math-import-isinf-for-uclibc-based-toolchains.patch [deleted file]
package/mesa3d/0003-meson-Set-proper-value-for-LIBCLC_INCLUDEDIR.patch
package/mesa3d/mesa3d.hash
package/mesa3d/mesa3d.mk

index 6e8c9be2c0a4be47391a385ebfac2962b4dc85ff..61848af59100c33567af8d82e84e056f0d4ccf09 100644 (file)
@@ -12,7 +12,7 @@ endif
 
 # Not possible to directly refer to mesa3d variables, because of
 # first/second expansion trickery...
-MESA3D_HEADERS_VERSION = 20.1.2
+MESA3D_HEADERS_VERSION = 20.1.3
 MESA3D_HEADERS_SOURCE = mesa-$(MESA3D_HEADERS_VERSION).tar.xz
 MESA3D_HEADERS_SITE = https://mesa.freedesktop.org/archive
 MESA3D_HEADERS_DL_SUBDIR = mesa3d
diff --git a/package/mesa3d/0002-c99_math-import-isinf-for-uclibc-based-toolchains.patch b/package/mesa3d/0002-c99_math-import-isinf-for-uclibc-based-toolchains.patch
new file mode 100644 (file)
index 0000000..5acbaa4
--- /dev/null
@@ -0,0 +1,30 @@
+From 705490763fcc052defa2d49a5c5200775cd12c54 Mon Sep 17 00:00:00 2001
+From: Peter Seiderer <ps.report@gmx.net>
+Date: Wed, 4 Mar 2020 08:27:24 +0100
+Subject: [PATCH] c99_math: import isinf for uclibc based toolchains
+
+The same fix as for glibc >= 2.23 is needed for uclibc
+based toolchains.
+
+[Upstream suggested: https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4042]
+Signed-off-by: Peter Seiderer <ps.report@gmx.net>
+---
+ include/c99_math.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/c99_math.h b/include/c99_math.h
+index e906c26aa54..c8a73a2d2c7 100644
+--- a/include/c99_math.h
++++ b/include/c99_math.h
+@@ -190,7 +190,7 @@ fpclassify(double x)
+  * undefines those functions, which in glibc 2.23, are defined as macros rather
+  * than functions as in glibc 2.22.
+  */
+-#if __cplusplus >= 201103L && (__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 23))
++#if __cplusplus >= 201103L && (__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 23) || defined(__UCLIBC__))
+ #include <cmath>
+ using std::fpclassify;
+-- 
+2.25.1
+
diff --git a/package/mesa3d/0003-c99_math-import-isinf-for-uclibc-based-toolchains.patch b/package/mesa3d/0003-c99_math-import-isinf-for-uclibc-based-toolchains.patch
deleted file mode 100644 (file)
index 5acbaa4..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-From 705490763fcc052defa2d49a5c5200775cd12c54 Mon Sep 17 00:00:00 2001
-From: Peter Seiderer <ps.report@gmx.net>
-Date: Wed, 4 Mar 2020 08:27:24 +0100
-Subject: [PATCH] c99_math: import isinf for uclibc based toolchains
-
-The same fix as for glibc >= 2.23 is needed for uclibc
-based toolchains.
-
-[Upstream suggested: https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4042]
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- include/c99_math.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/include/c99_math.h b/include/c99_math.h
-index e906c26aa54..c8a73a2d2c7 100644
---- a/include/c99_math.h
-+++ b/include/c99_math.h
-@@ -190,7 +190,7 @@ fpclassify(double x)
-  * undefines those functions, which in glibc 2.23, are defined as macros rather
-  * than functions as in glibc 2.22.
-  */
--#if __cplusplus >= 201103L && (__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 23))
-+#if __cplusplus >= 201103L && (__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 23) || defined(__UCLIBC__))
- #include <cmath>
- using std::fpclassify;
--- 
-2.25.1
-
index 072d79a2130fa88a6a6981e341d28b2a2b720478..6293b8fba449af94d4e5ed0b8e68f87d7b3066b7 100644 (file)
@@ -25,9 +25,9 @@ diff --git a/src/gallium/state_trackers/clover/meson.build b/src/gallium/state_t
 index 62ac5f5278d..ecdeb39669c 100644
 --- a/src/gallium/state_trackers/clover/meson.build
 +++ b/src/gallium/state_trackers/clover/meson.build
-@@ -49,7 +49,7 @@ libclllvm = static_library(
-   include_directories : clover_incs,
-   cpp_args : [
+@@ -64,7 +64,7 @@
+     clover_opencl_cpp_args,
+     clover_spirv_cpp_args,
      cpp_vis_args,
 -    '-DLIBCLC_INCLUDEDIR="@0@/"'.format(dep_clc.get_pkgconfig_variable('includedir')),
 +    '-DLIBCLC_INCLUDEDIR="/usr/share"',
index 9fdf30e0134fc574e76781197afeb4da3d543061..1524315f455c143fb957371a27149e2c323066ba 100644 (file)
@@ -1,6 +1,6 @@
-# From https://lists.freedesktop.org/archives/mesa-announce/2020-June/000589.html
-sha256  283dff72814c8a80ce1ff8271e3f055895d26f4da3f4362acc49193e635780cb  mesa-20.1.2.tar.xz
-sha512  467fc6a1cbfc1bc140ba2e6e90a14bd8d15d979b92ba14d084018b6cf22b172767575f5127c6edb5c3bdf12fe6696b27d9975826b3fbb5ad5909d258fc3b8433  mesa-20.1.2.tar.xz
+# From https://lists.freedesktop.org/archives/mesa-announce/2020-July/000590.html
+sha256  9872b8d46bee822177ffbe4292addff7bdb84cefc1fe776b8e6b2881a8362bf1  mesa-20.1.3.tar.xz
+sha512  c3134cda6a07041c2cacd783663c0618e97f907bb0e67718a5c8fb03f4608ba47f0cd5adb6f0400a44f15fd70f3b41d66da1376035ba4e4f4f97a1843dcb1f77  mesa-20.1.3.tar.xz
 
 # License
 sha256  1ddae7da415352a5b5360ff3a9d7ecf23ba81408f62eeecce0011f32e3ef9da6  docs/license.html
index 9eb0993f02d32d39c43f9fa7277f608a54c590c9..146b7e31412e813c196994f1261fcaa2c675581a 100644 (file)
@@ -5,7 +5,7 @@
 ################################################################################
 
 # When updating the version, please also update mesa3d-headers
-MESA3D_VERSION = 20.1.2
+MESA3D_VERSION = 20.1.3
 MESA3D_SOURCE = mesa-$(MESA3D_VERSION).tar.xz
 MESA3D_SITE = https://mesa.freedesktop.org/archive
 MESA3D_LICENSE = MIT, SGI, Khronos