midori: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:59:46 +0000 (22:59 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:28:45 +0000 (01:28 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/midori/Config.in
package/midori/midori.mk

index 4d30c83066d7ce73c520210c85dc6421ae8a6a09..43ba45e8013eba1a5631da03f256c6d47b78b7a1 100644 (file)
@@ -21,7 +21,6 @@ config BR2_PACKAGE_MIDORI
        select BR2_PACKAGE_LIBXML2
        select BR2_PACKAGE_SQLITE
        select BR2_PACKAGE_WEBKITGTK
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        help
          Midori is a lightweight web browser based on WebKit
index 395e72ec2f2e77ac8f7b3b63c8b38d0ff97e9197..1755f1241a0270ade7107907fd6d7f6d486c2df1 100644 (file)
@@ -22,7 +22,7 @@ MIDORI_DEPENDENCIES = \
        libxml2 \
        sqlite \
        webkitgtk \
-       $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) \
+       $(TARGET_NLS_DEPENDENCIES) \
        $(if $(BR2_PACKAGE_LIBICONV),libiconv)
 
 MIDORI_CONF_OPTS = \