cjson: add comment explaining how BUILD_SHARED_AND_STATIC_LIBS works
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 3 Jan 2018 21:30:44 +0000 (22:30 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 3 Jan 2018 21:31:30 +0000 (22:31 +0100)
This was missing in commit aca8412ce27fdb216e80145933baa13c15118719
("cjson: build shared and static library").

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cjson/cjson.mk

index aabf3677eadcfe6cd618025c09877467f40bd559..6dff7d6567be16e02b2a46ef1cadc2632008f529 100644 (file)
@@ -15,6 +15,9 @@ CJSON_CONF_OPTS += \
        -DENABLE_CJSON_TEST=OFF \
        -DENABLE_CUSTOM_COMPILER_FLAGS=OFF
 
+# If BUILD_SHARED_AND_STATIC_LIBS is set to OFF, cjson uses the
+# standard BUILD_SHARED_LIBS option which is passed by the
+# cmake-package infrastructure.
 ifeq ($(BR2_SHARED_STATIC_LIBS),y)
 CJSON_CONF_OPTS += -DBUILD_SHARED_AND_STATIC_LIBS=ON
 else