berkeleydb: add compat option
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 2 Dec 2013 00:29:15 +0000 (21:29 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Dec 2013 07:45:10 +0000 (08:45 +0100)
Add DB 1.85 compatibility layer option, it's needed for arpd in iproute2
and other old apps that haven't moved to the newer API.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/berkeleydb/Config.in
package/berkeleydb/berkeleydb.mk

index a597abbe8a724286468ed804c1fe71757e35a0cd..ff1e386877099e21e3aa671a1791fbc621a2ee0c 100644 (file)
@@ -6,8 +6,16 @@ config BR2_PACKAGE_BERKELEYDB
 
          http://www.sleepycat.com/products/db.shtml
 
+if BR2_PACKAGE_BERKELEYDB
+
+config BR2_PACKAGE_BERKELEYDB_COMPAT185
+       bool "DB 1.85 compatibility"
+       help
+         Build and install DB 1.85 compatibility API.
+
 config BR2_PACKAGE_BERKELEYDB_TOOLS
        bool "install tools"
-       depends on BR2_PACKAGE_BERKELEYDB
        help
          Install berkeleydb tools, mostly useful for debugging purposes.
+
+endif
index 0e3e83068596a8c30ac14a8ede6cc4b461bae721..f3250208a3908906585d90f9d76fc503ab5ab908 100644 (file)
@@ -36,7 +36,7 @@ define BERKELEYDB_CONFIGURE_CMDS
                $(if $(BR2_INSTALL_LIBSTDCPP),--enable-cxx,--disable-cxx) \
                --disable-java \
                --disable-tcl \
-               --disable-compat185 \
+               $(if $(BR2_PACKAGE_BERKELEYDB_COMPAT185),--enable-compat185,--disable-compat185) \
                $(SHARED_STATIC_LIBS_OPTS) \
                --with-pic \
                --enable-o_direct \