package/xbmc: Add optional support for libcap
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 25 Oct 2014 18:19:55 +0000 (20:19 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 26 Oct 2014 04:45:47 +0000 (05:45 +0100)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/xbmc/xbmc.mk

index 86a9721f7390d5914e9981f299767b57668c9806..03362c21bc08d0b5c45afe791d3c37432a51b02a 100644 (file)
@@ -63,6 +63,13 @@ XBMC_CONF_ENV += INCLUDES="-I$(STAGING_DIR)/usr/include/interface/vcos/pthreads
        LIBS="-lvcos -lvchostif"
 endif
 
+ifeq ($(BR2_PACKAGE_LIBCAP),y)
+XBMC_CONF_OPTS += --enable-libcap
+XBMC_DEPENDENCIES += libcap
+else
+XBMC_CONF_OPTS += --disable-libcap
+endif
+
 ifeq ($(BR2_PACKAGE_XBMC_DBUS),y)
 XBMC_DEPENDENCIES += dbus
 XBMC_CONF_OPTS += --enable-dbus