external toolchain: copy the C++ standard library if needed
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 16 Jul 2009 22:26:23 +0000 (00:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 17 Jul 2009 06:46:51 +0000 (08:46 +0200)
Obey the BR2_INSTALL_LIBSTDCPP configuration option to copy the C++
standard library to the target. Suggested by Lionel Landwerlin
<lionel.landwerlin@openwide.fr>.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/external-toolchain/ext-tool.mk

index 6df48f0b0b6a29dfd59734b383447d5837489fa3..e772cda7ea217407cd8328326e63623f78b44175 100644 (file)
@@ -190,6 +190,10 @@ else
 EXTERNAL_LIBS+=ld-linux.so libnss_files.so
 endif
 
+ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+EXTERNAL_LIBS+=libstdc++.so
+endif
+
 SYSROOT_DIR=$(shell LANG=C $(TARGET_CC) -v 2>&1 | grep ^Configured | tr " " "\n" | grep -- "--with-sysroot" | cut -f2 -d=)
 
 $(STAMP_DIR)/ext-toolchain-installed: