speex: fix target install
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 17 Aug 2008 13:20:31 +0000 (13:20 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 17 Aug 2008 13:20:31 +0000 (13:20 -0000)
Use install-strip and clean up documentation files instead of
install-exec so files get stripped and manpages installed if
requested.

package/speex/speex.mk

index a28236b54e114894cb2f9a3ad1ad2b1dd7ce304e..4aabe8bc6b94a675627f5bb52d0c1415945a5cb3 100644 (file)
@@ -9,6 +9,7 @@ SPEEX_SITE=http://downloads.us.xiph.org/releases/speex
 SPEEX_AUTORECONF = NO
 SPEEX_INSTALL_STAGING = YES
 SPEEX_INSTALL_TARGET = YES
+SPEEX_INSTALL_TARGET_OPT:=DESTDIR=$(TARGET_DIR) install-strip
 SPEEX_DEPENDENCIES = libogg
 SPEEX_CONF_OPT = --with-ogg-libraries=$(STAGING_DIR)/usr/lib --with-ogg-includes=$(STAGING_DIR)/usr/include \
                --disable-static --enable-fixed-point $(DISABLE_NLS)
@@ -25,3 +26,7 @@ $(SPEEX_TARGET_BUILD): $(SPEEX_TARGET_CONFIGURE)
        $(SED) 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' $(SPEEX_DIR)/libtool
        $($(PKG)_MAKE_ENV) $(MAKE) $($(PKG)_MAKE_OPT) -C $(@D)/$($(PKG)_SUBDIR)
        $(Q)touch $@
+
+$(SPEEX_HOOK_POST_INSTALL): $(SPEEX_TARGET_INSTALL_TARGET)
+       rm -rf $(TARGET_DIR)/usr/share/doc/speex $(TARGET_DIR)/usr/share/aclocal
+       touch $@