- propagate mips ISA down to uClibc
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sun, 30 Sep 2007 12:42:59 +0000 (12:42 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sun, 30 Sep 2007 12:42:59 +0000 (12:42 -0000)
toolchain/uClibc/uclibc.mk

index 1bef774f0c0550f9f6bbd26069d323b6d01a1a9e..9ce47289ab996f8c5a86b7a7d4e0e33a2b4ac555 100644 (file)
@@ -150,9 +150,16 @@ endif
 endif
 ifeq ($(UCLIBC_TARGET_ARCH),mips)
        $(SED) '/CONFIG_MIPS_[NO].._ABI/d' $(UCLIBC_DIR)/.oldconfig
+       $(SED) '/CONFIG_MIPS_ISA_.*/d' $(UCLIBC_DIR)/.oldconfig
        (/bin/echo "# CONFIG_MIPS_O32_ABI is not set"; \
         /bin/echo "# CONFIG_MIPS_N32_ABI is not set"; \
         /bin/echo "# CONFIG_MIPS_N64_ABI is not set"; \
+        /bin/echo "# CONFIG_MIPS_ISA_1 is not set"; \
+        /bin/echo "# CONFIG_MIPS_ISA_2 is not set"; \
+        /bin/echo "# CONFIG_MIPS_ISA_3 is not set"; \
+        /bin/echo "# CONFIG_MIPS_ISA_4 is not set"; \
+        /bin/echo "# CONFIG_MIPS_ISA_MIPS32 is not set"; \
+        /bin/echo "# CONFIG_MIPS_ISA_MIPS64 is not set"; \
        ) >> $(UCLIBC_DIR)/.oldconfig
 ifeq ($(BR2_MIPS_OABI),y)
        $(SED) 's/.*\(CONFIG_MIPS_O32_ABI\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
@@ -163,6 +170,27 @@ endif
 ifeq ($(BR2_MIPS_ABI64),y)
        $(SED) 's/.*\(CONFIG_MIPS_N64_ABI\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
 endif
+ifeq ($(BR2_mips_1),y)
+       $(SED) 's/.*\(CONFIG_MIPS_ISA_1\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_mips_2),y)
+       $(SED) 's/.*\(CONFIG_MIPS_ISA_2\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_mips_3),y)
+       $(SED) 's/.*\(CONFIG_MIPS_ISA_3\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_mips_4),y)
+       $(SED) 's/.*\(CONFIG_MIPS_ISA_4\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_mips_32),y)
+       $(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS32\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_mips_32r2),y)
+       $(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS32\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_mips_64),y)
+       $(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS64\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+endif
 endif
 ifeq ($(UCLIBC_TARGET_ARCH),sh)
        /bin/echo "# CONFIG_SH2A is not set" >> $(UCLIBC_DIR)/.oldconfig