toolchain-external: update Linaro toolchains
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 10 Nov 2014 10:06:31 +0000 (11:06 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 11 Nov 2014 20:15:26 +0000 (21:15 +0100)
Bump the ARM, ARMeb and AArch64 Linaro toolchains from 14.08 to
14.09. We can't bump to 14.10, because they completely changed the
toolchains and they are now completely broken: they switched from
Crosstool-NG to a new build tool to generate the toolchain, and now
the sysroot handling is completely borked.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/toolchain-external.mk

index 39b56e1f55a637d68b5e5f4e32ada3b7734f8b1f..c9feac3022901fe1e4244bae792acbb27399f9e5 100644 (file)
@@ -7,7 +7,7 @@ comment "(e)glibc toolchains only available with shared lib support"
        depends on BR2_PREFER_STATIC_LIB
 
 config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARM
-       bool "Linaro ARM 2014.08"
+       bool "Linaro ARM 2014.09"
        depends on BR2_arm
        depends on BR2_ARM_CPU_ARMV7A
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
@@ -20,8 +20,8 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARM
        select BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_1
        help
          Linaro toolchain for the ARM architecture. It uses Linaro
-         GCC 2014.08 (based on gcc 4.9), Linaro GDB 2013.10 (based on
-         GDB 7.6), eglibc 2.19, Binutils 2014.08 (based on 2.24). It
+         GCC 2014.09 (based on gcc 4.9), Linaro GDB 2013.10 (based on
+         GDB 7.6), eglibc 2.19, Binutils 2014.09 (based on 2.24). It
          generates code that runs on all Cortex-A profile devices,
          but tuned for the Cortex-A9. The code generated is Thumb 2,
          with the hard floating point calling convention, and uses
@@ -33,7 +33,7 @@ comment "Linaro toolchains available for Cortex-A + EABIhf"
        depends on !BR2_PREFER_STATIC_LIB
 
 config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARMEB
-       bool "Linaro armeb 2014.08"
+       bool "Linaro armeb 2014.09"
        depends on BR2_armeb
        depends on BR2_ARM_CPU_ARMV7A
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
@@ -46,8 +46,8 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARMEB
        select BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_1
        help
          Linaro toolchain for the ARM big endian architecture. It
-         uses Linaro GCC 2014.08 (based on gcc 4.9), Linaro GDB
-         2013.10 (based on GDB 7.6), eglibc 2.19, Binutils 2014.08
+         uses Linaro GCC 2014.09 (based on gcc 4.9), Linaro GDB
+         2013.10 (based on GDB 7.6), eglibc 2.19, Binutils 2014.09
          (based on 2.24). It generates code that runs on all Cortex-A
          profile devices, but tuned for the Cortex-A9. The code
          generated is Thumb 2, with the hard floating point calling
@@ -813,7 +813,7 @@ config BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEBE_V2
          http://wiki.xilinx.com/mb-gnu-tools
 
 config BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64
-       bool "Linaro AArch64 14.08"
+       bool "Linaro AArch64 14.09"
        depends on BR2_aarch64
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
        depends on !BR2_PREFER_STATIC_LIB
index e16fce5887c6138199e521a3079ce331e9f54aee..da3718c4a8baa50616a081f9d4dcff7f2736a8b2 100644 (file)
@@ -271,12 +271,12 @@ define TOOLCHAIN_EXTERNAL_FIXUP_CMDS
        rm -rf $(TOOLCHAIN_EXTERNAL_INSTALL_DIR)/arago-2011.09/
 endef
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_ARM),y)
-TOOLCHAIN_EXTERNAL_SITE = http://releases.linaro.org/14.08/components/toolchain/binaries/
-TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-arm-linux-gnueabihf-4.9-2014.08_linux.tar.xz
+TOOLCHAIN_EXTERNAL_SITE = http://releases.linaro.org/14.09/components/toolchain/binaries/
+TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-arm-linux-gnueabihf-4.9-2014.09_linux.tar.xz
 TOOLCHAIN_EXTERNAL_POST_INSTALL_STAGING_HOOKS += TOOLCHAIN_EXTERNAL_LINARO_ARMHF_SYMLINK
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_ARMEB),y)
-TOOLCHAIN_EXTERNAL_SITE = http://releases.linaro.org/14.08/components/toolchain/binaries/
-TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-armeb-linux-gnueabihf-4.9-2014.08_linux.tar.xz
+TOOLCHAIN_EXTERNAL_SITE = http://releases.linaro.org/14.09/components/toolchain/binaries/
+TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-armeb-linux-gnueabihf-4.9-2014.09_linux.tar.xz
 TOOLCHAIN_EXTERNAL_POST_INSTALL_STAGING_HOOKS += TOOLCHAIN_EXTERNAL_LINARO_ARMEBHF_SYMLINK
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201305),y)
 TOOLCHAIN_EXTERNAL_SITE = http://sourcery.mentor.com/public/gnu_toolchain/mips-linux-gnu/
@@ -352,8 +352,8 @@ else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEBE_V2),y)
 TOOLCHAIN_EXTERNAL_SITE = http://sources.buildroot.net/
 TOOLCHAIN_EXTERNAL_SOURCE = microblaze-unknown-linux-gnu.tgz
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64),y)
-TOOLCHAIN_EXTERNAL_SITE = http://releases.linaro.org/14.08/components/toolchain/binaries/
-TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-aarch64-linux-gnu-4.9-2014.08_linux.tar.xz
+TOOLCHAIN_EXTERNAL_SITE = http://releases.linaro.org/14.09/components/toolchain/binaries/
+TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-aarch64-linux-gnu-4.9-2014.09_linux.tar.xz
 TOOLCHAIN_EXTERNAL_POST_INSTALL_STAGING_HOOKS += TOOLCHAIN_EXTERNAL_LINARO_AARCH64_SYMLINK
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_AARCH64),y)
 TOOLCHAIN_EXTERNAL_SITE = http://sourcery.mentor.com/public/gnu_toolchain/aarch64-linux-gnu/