lbase64: compile with -fPIC
authorFrancois Perrad <fperrad@gmail.com>
Fri, 29 Sep 2017 16:59:06 +0000 (18:59 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Fri, 6 Oct 2017 18:42:22 +0000 (20:42 +0200)
Some architectures (e.g. x86_64, MIPS, microblaze, or1k) require to
build with -fPIC to build a shared library, but the lbase64 build
system doesn't add it. Therefore, we add it in CFLAGS.

Fixes:
http://autobuild.buildroot.net/results/b56/b567096cbfdb89b1895924051265c56204ffb512/

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
[Arnout: write commit log]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/lbase64/lbase64.mk

index fd78a6ccd4fe0c0fbf6dafef4ccda3381d4548ee..0225fc67c7c1412fa42ee741d170cdb18889d905 100644 (file)
@@ -12,7 +12,8 @@ LBASE64_LICENSE_FILES = README
 LBASE64_DEPENDENCIES = luainterpreter
 
 define LBASE64_BUILD_CMDS
-       $(MAKE1) $(TARGET_CONFIGURE_OPTS) -C $(@D) so
+       $(MAKE1) $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) -fPIC" -C $(@D) so
 endef
 
 define LBASE64_INSTALL_TARGET_CMDS