tcl: switch to * instead of [0-9]
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Wed, 30 Mar 2016 16:14:07 +0000 (17:14 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Mar 2016 17:26:57 +0000 (19:26 +0200)
Those [0-9] expressions are needlessly complex, and they actually no
longer work now that sqlite3.11.0 is bundled internally (11 is two
digits, which was accounted for).

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tcl/tcl.mk

index 9fd11954c6c379f26c1f47f9c7efc8bec213e5df..10a37c303f74b7816f41b1c69669914830e30540 100644 (file)
@@ -32,21 +32,16 @@ HOST_TCL_CONF_OPTS = \
 # I haven't found a good way to force pkgs to not build
 # or configure without just removing the entire pkg directory.
 define HOST_TCL_REMOVE_PACKAGES
-       rm -fr $(@D)/pkgs/sqlite[0-9].[0-9].[0-9] \
-               $(@D)/pkgs/tdbc[0-9].[0-9].[0-9] \
-               $(@D)/pkgs/tdbcmysql[0-9].[0-9].[0-9] \
-               $(@D)/pkgs/tdbcodbc[0-9].[0-9].[0-9] \
-               $(@D)/pkgs/tdbcpostgres[0-9].[0-9].[0-9] \
-               $(@D)/pkgs/tdbcsqlite3-[0-9].[0-9].[0-9]
+       rm -fr $(@D)/pkgs/sqlite3* $(@D)/pkgs/tdbc*
 endef
 HOST_TCL_PRE_CONFIGURE_HOOKS += HOST_TCL_REMOVE_PACKAGES
 define TCL_REMOVE_PACKAGES
-       rm -fr $(if $(BR2_PACKAGE_SQLITE),,$(@D)/pkgs/sqlite[0-9].[0-9].[0-9]) \
-               $(if $(BR2_PACKAGE_SQLITE),,$(@D)/pkgs/tdbc[0-9].[0-9].[0-9]) \
-               $(@D)/pkgs/tdbcmysql[0-9].[0-9].[0-9] \
-               $(@D)/pkgs/tdbcodbc[0-9].[0-9].[0-9] \
-               $(@D)/pkgs/tdbcpostgres[0-9].[0-9].[0-9] \
-               $(if $(BR2_PACKAGE_SQLITE),,$(@D)/pkgs/tdbcsqlite3-[0-9].[0-9].[0-9])
+       rm -fr $(if $(BR2_PACKAGE_SQLITE),,$(@D)/pkgs/sqlite3*) \
+               $(if $(BR2_PACKAGE_SQLITE),,$(@D)/pkgs/tdbc1*) \
+               $(@D)/pkgs/tdbcmysql* \
+               $(@D)/pkgs/tdbcodbc* \
+               $(@D)/pkgs/tdbcpostgres* \
+               $(if $(BR2_PACKAGE_SQLITE),,$(@D)/pkgs/tdbcsqlite3*)
 endef
 TCL_PRE_CONFIGURE_HOOKS += TCL_REMOVE_PACKAGES