toolchain/toolchain-external: install ldd on the target
authorJulien Boibessot <julien.boibessot@armadeus.com>
Wed, 22 Apr 2020 15:34:42 +0000 (17:34 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 27 Apr 2020 20:55:19 +0000 (22:55 +0200)
From: Julien Boibessot <julien.boibessot@armadeus.com>

It could be usefull to have ldd on the target so install it.

Signed-off-by: Julien Boibessot <julien.boibessot@armadeus.com>
[Sébastien: add commit message]
Signed-off-by: Sébastien Szymanski <sebastien.szymanski@armadeus.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
toolchain/toolchain-external/pkg-toolchain-external.mk

index 8667d7ddf6732fd51edb7ff159e9bf684ce312c7..6d91cb5d1ed316a35ff9ee6f4ded50a1c571940c 100644 (file)
@@ -499,6 +499,12 @@ define TOOLCHAIN_EXTERNAL_FIXUP_UCLIBCNG_LDSO
        fi
 endef
 
+define TOOLCHAIN_EXTERNAL_INSTALL_TARGET_LDD
+       $(Q)if test -f $(STAGING_DIR)/usr/bin/ldd ; then \
+               $(INSTALL) -D $(STAGING_DIR)/usr/bin/ldd $(TARGET_DIR)/usr/bin/ldd ; \
+               $(SED) 's:.*/bin/bash:#!/bin/sh:' $(TARGET_DIR)/usr/bin/ldd ; \
+       fi
+endef
 
 ################################################################################
 # inner-toolchain-external-package -- defines the generic installation rules
@@ -593,6 +599,7 @@ define $(2)_INSTALL_TARGET_CMDS
        $$(TOOLCHAIN_EXTERNAL_INSTALL_TARGET_LIBS)
        $$(TOOLCHAIN_EXTERNAL_INSTALL_TARGET_GDBSERVER)
        $$(TOOLCHAIN_EXTERNAL_FIXUP_UCLIBCNG_LDSO)
+       $$(TOOLCHAIN_EXTERNAL_INSTALL_TARGET_LDD)
 endef
 
 # Call the generic package infrastructure to generate the necessary