projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
cd72e95
)
grep: fix build when libiconv is enabled
author
Peter Korsgaard
<jacmet@sunsite.dk>
Sat, 25 Dec 2010 21:33:20 +0000
(22:33 +0100)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Sat, 25 Dec 2010 21:33:20 +0000
(22:33 +0100)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/grep/grep.mk
patch
|
blob
|
history
diff --git
a/package/grep/grep.mk
b/package/grep/grep.mk
index e323b1de9326997c660e5f5fe84b6048480eaef4..bfc9116633b5681150e01aaae2034a9fbc44e575 100644
(file)
--- a/
package/grep/grep.mk
+++ b/
package/grep/grep.mk
@@
-9,4
+9,10
@@
GREP_SITE = $(BR2_GNU_MIRROR)/grep
GREP_CONF_OPT = --disable-perl-regexp --without-included-regex
GREP_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext libintl)
+# link with iconv if enabled
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+GREP_CONF_ENV += LIBS=-liconv
+GREP_DEPENDENCIES += libiconv
+endif
+
$(eval $(call AUTOTARGETS,package,grep))