ipmitool: new package
authorFloris Bos <bos@je-eigen-domein.nl>
Thu, 11 Sep 2014 23:12:48 +0000 (01:12 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 13 Sep 2014 19:57:03 +0000 (21:57 +0200)
Adds ipmitool, a command-line interface to IPMI-enabled devices.

Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/ipmitool/Config.in [new file with mode: 0644]
package/ipmitool/ipmitool.mk [new file with mode: 0644]

index 883dd66a3cd898f979aed6fc8488ca4b20ae1fb9..302a63843419253490710ff45a22fec870994879 100644 (file)
@@ -321,6 +321,7 @@ endif
        source "package/input-tools/Config.in"
        source "package/intel-microcode/Config.in"
        source "package/iostat/Config.in"
+       source "package/ipmitool/Config.in"
        source "package/irda-utils/Config.in"
        source "package/iucode-tool/Config.in"
        source "package/kbd/Config.in"
diff --git a/package/ipmitool/Config.in b/package/ipmitool/Config.in
new file mode 100644 (file)
index 0000000..e9b5374
--- /dev/null
@@ -0,0 +1,26 @@
+config BR2_PACKAGE_IPMITOOL
+       bool "ipmitool"
+       depends on BR2_USE_MMU # fork()
+       help
+         IPMItool provides a simple command-line interface to IPMI-enabled devices.
+
+         http://sourceforge.net/projects/ipmitool/
+
+if BR2_PACKAGE_IPMITOOL
+
+config BR2_PACKAGE_IPMITOOL_LANPLUS
+       bool "enable lanplus interface"
+       select BR2_PACKAGE_OPENSSL
+       help
+         Enables the IPMI v2.0 RMCP+ LAN interface typically used to send IPMI
+         commands to the BMC of a remote server.
+         Not needed if you only want to communicate with the local BMC of your
+         device using the OpenIPMI ipmi_si kernel module, or if using the
+         legacy IPMI v1.5 RMCP LAN interface.
+
+config BR2_PACKAGE_IPMITOOL_IPMIEVD
+       bool "ipmievd"
+       help
+         IPMI event daemon for sending events to syslog
+
+endif
diff --git a/package/ipmitool/ipmitool.mk b/package/ipmitool/ipmitool.mk
new file mode 100644 (file)
index 0000000..85be883
--- /dev/null
@@ -0,0 +1,30 @@
+################################################################################
+#
+# ipmitool
+#
+################################################################################
+
+IPMITOOL_VERSION = 1.8.14
+IPMITOOL_SOURCE = ipmitool-$(IPMITOOL_VERSION).tar.bz2
+IPMITOOL_SITE = http://downloads.sourceforge.net/project/ipmitool/ipmitool/$(IPMITOOL_VERSION)
+IPMITOOL_LICENSE = BSD-3c
+IPMITOOL_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_PACKAGE_IPMITOOL_LANPLUS),y)
+IPMITOOL_DEPENDENCIES += openssl
+else
+IPMITOOL_CONF_OPT += --disable-intf-lanplus
+endif
+
+ifeq ($(BR2_PACKAGE_READLINE),y)
+IPMITOOL_DEPENDENCIES += readline
+endif
+
+ifeq ($(BR2_PACKAGE_IPMITOOL_IPMIEVD),)
+define IPMITOOL_REMOVE_IPMIEVD
+       $(RM) -f $(TARGET_DIR)/usr/sbin/ipmievd
+endef
+IPMITOOL_POST_INSTALL_TARGET_HOOKS += IPMITOOL_REMOVE_IPMIEVD
+endif
+
+$(eval $(autotools-package))