sstrip: remove deprecated package
authorArnout Vandecappelle <arnout@mind.be>
Sat, 15 Oct 2016 14:51:02 +0000 (16:51 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 15 Oct 2016 21:14:45 +0000 (23:14 +0200)
We will remove BR2_DEPRECATED, so remove this deprecated package.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/Config.in
package/sstrip/Config.in [deleted file]
package/sstrip/sstrip.mk [deleted file]

index 76365e6f72da58c58f8f44dc6a22dd576f226051..1fcedfe91f13dfe0cfe4bd5ff4d76b4ef8466bbc 100644 (file)
@@ -145,6 +145,15 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2016.11"
 
+config BR2_PACKAGE_SSTRIP
+       bool "sstrip removed"
+       select BR2_LEGACY
+       help
+         sstrip is unmaintained and potentially harmful. It doesn't
+         save so much compared to normal binutils strip, and there is
+         a big risk of binaries that don't work. Use normal strip
+         instead.
+
 config BR2_KERNEL_HEADERS_4_3
        bool "kernel headers version 4.3.x are no longer supported"
        select BR2_KERNEL_HEADERS_4_1
index 0257685ccb89b2097bb9bfe5f48f830ca085fb62..47c08015bc70b5728a72170e0ed3c68de11db6cb 100644 (file)
@@ -143,7 +143,6 @@ menu "Development tools"
        source "package/patch/Config.in"
        source "package/pkgconf/Config.in"
        source "package/sed/Config.in"
-       source "package/sstrip/Config.in"
        source "package/subversion/Config.in"
        source "package/tree/Config.in"
        source "package/yasm/Config.in"
diff --git a/package/sstrip/Config.in b/package/sstrip/Config.in
deleted file mode 100644 (file)
index c458f8e..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-config BR2_PACKAGE_SSTRIP
-       bool "sstrip"
-       depends on BR2_DEPRECATED_SINCE_2016_08
-       help
-         Small utility that removes a few bytes from an executable that
-         strip leaves behind.
-
-         http://www.muppetlabs.com/~breadbox/software/elfkickers.html
diff --git a/package/sstrip/sstrip.mk b/package/sstrip/sstrip.mk
deleted file mode 100644 (file)
index 685ea09..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-################################################################################
-#
-# sstrip
-#
-################################################################################
-
-SSTRIP_SITE = svn://svn.openwrt.org/openwrt/trunk/tools/sstrip
-SSTRIP_VERSION = 20154
-
-define SSTRIP_BUILD_CMDS
-       cd $(@D) ; \
-       $(TARGET_CC) $(TARGET_CFLAGS) -include endian.h -include byteswap.h \
-               -o sstrip src/sstrip.c
-endef
-
-define SSTRIP_INSTALL_TARGET_CMDS
-       $(INSTALL) -D $(@D)/sstrip $(TARGET_DIR)/usr/bin/sstrip
-endef
-
-$(eval $(generic-package))